HDU 6518 Clumsy Keke (思维)

Clumsy Keke

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 88    Accepted Submission(s): 30


 

Problem Description

Keke is currently studying engineering drawing courses, and the teacher has taught her how to find its volume through the three views of the part. But her brain doesn't work well that she can't find the volume of complex parts. So she needs your help.

To simplify the problem, the part is made up of cubes with side length 1, and the vertices of these cubes are all on the grid. Give you three 0/1 matrices, each representing each of the three views. 0 means that there is no projection of cubes at this position of the view; 1 means that there is a projection of cubes at this position of the view.

Now Keke wants you to help her find the volume of the part determined by the three views.

 

 

Input

There are mutiple test cases, the number of which is no more than 10. For each test case:

The first line of input contains three integers mx,my,mz(1≤mx,my,mz≤99) , which represent the coordinate range of all possible cubes (i.e. all possible cubes are in the cuboid area whose body diagonal is from (1,1,1) to (mx,my,mz)).

Following input a 0/1 matrix with mx lines and my columns representing the front view, and the y-th column of the x-th row represents the projection of all the cubes in the front view such as (x,y,?).

Following input a 0/1 matrix with my lines and mz columns representing the side view, and the z-th column of the y-th row represents the projections of all the cubes in the side view such as (?,y,z).

Following input a 0/1 matrix with mz lines and mx columns representing the top view, and the x-th column of the z-th row represents the projection of all the cubes of the top view such as (x,?,z).

The '?' in the above coordinates represents any integer. Numbers in the same line are separated by spaces. For more detailed input information, please see the sample.

 

 

Output

For each test case:

The first line of output should contain an integer, representing the volume of the part determined by the three views. If the determined part is not unique, find the largest of all possible parts.

Keke's teacher promises that there is at least one part that satisfies the input.

 

 

Sample Input

 

5 6 4 1 1 1 1 1 1 0 0 0 1 0 1 0 0 0 1 0 1 0 0 0 0 0 1 0 0 0 0 0 1 0 1 1 0 1 0 0 1 0 0 0 1 0 0 0 1 0 0 0 1 1 1 1 1 1 0 0 0 0 1 0 0 0 0 1 0 0 0 0 1 1 1 1 1

 

 

Sample Output

 

17

Hint

 

 

 

Source

2019中山大学程序设计竞赛(重现赛)

题意:

给你三视图,求由三视图至少能确定的小立方体个数。

思路:

有很多奇怪的解法,也不知道是不是数据水。这里我采用大佬的一个最直接的方法:

对于俯视图,如果某个格子为0,那么意味着这一整列都没有格子。开个三维数组标记一下。

主视图和左视图同理。

最后统计没被标记到的格子数量即可。

注意,出题人日常卡内存,数组不要开得太大。

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
#define rep(i,a,b) for(register int i=(a);i<=(b);i++)
#define dep(i,a,b) for(register int i=(a);i>=(b);i--)
using namespace std;
const int maxn=110;
int n,m,k;
int a[maxn][maxn][maxn];
int main()
{
    int T,cas=1;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF){
        memset(a,0,sizeof(a));
        rep(i,1,n)
        rep(j,1,m)
        {
            int x;
            scanf("%d",&x);
            if(!x)
            rep(t,1,k) a[i][j][t]=1;
        }
        rep(i,1,m)
        rep(j,1,k)
        {
            int x;
            scanf("%d",&x);
            if(!x)
            rep(t,1,n) a[t][i][j]=1;
        }
        rep(i,1,k)
        rep(j,1,n)
        {
            int x;
            scanf("%d",&x);
            if(!x)
            rep(t,1,m) a[j][t][i]=1;
        }
        int ans=0;
        rep(i,1,n)
        {
            rep(j,1,m)
            {
                rep(t,1,k)
                {
                    ans+=(a[i][j][t]==0);
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值