hdu 2899 Strange fuction(二分+数学)

题目来源:hdu 2899 Strange fuction

Strange fuction
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4829 Accepted Submission(s): 3441

Problem Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input
2
100
200

Sample Output
-74.4291
-178.8534

题目大意:
给出一个函数:F(x)=6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100);现在输入一个y值.(0 < Y <1e10),求此函数的最小值。
题目分析:
观察函数,我们可知,F(x)一阶导数为F’(x)=42 * x^6+48*x^5+21*x^2+10*x-y;而F’(x)中若不看y,则前面的式子为单增函数,当输入y值后,我们便可把y当做常数来处理,当y值大于前面式子的最大值,即F’(100)<0时,原函数F(x)单调递减,此时F(100)为最小值;而当y不大于前面的式子,即存在y使得F’(x)可以==0时,则我们可以知道,x取F’(x)==0的这个x值时,原函数F(x)取得最小值,在此处便需要使用二分来查找这个x值。
AC代码:

#include<stdio.h>
#include<math.h>
double F(double x)      //将原函数分解为F(x)-y*x,此处求的是分解后的F(x)值 
{
    return 6*pow(x,7.0)+8*pow(x,6.0)+7*pow(x,3.0)+5*pow(x,2.0);
}
double f(double x)      //分解后的F'(x)的值 
{
    return 42*pow(x,6.0)+48*pow(x,5.0)+21*pow(x,2.0)+10*pow(x,1.0);
}
int main()
{
    int n;
    double y;
    while(scanf("%d",&n)!=EOF)
    {
        while(n--)
        {
            scanf("%lf",&y);
            if(y>=F(100))           //此时原函数的导数不存在等于0的情况,即小于零 
                printf("%.4lf\n",F(100)-y*100);
            else
            {
                double mid,left=0,right=100;
                while(right-left>1e-8)  //使用二分进行查找使得分解后的F(x)的导数等于0的x 
                {
                    mid=(left+right)/2;
                    if(f(mid)<=y)
                        left=mid;
                    else
                        right=mid;
                }
                printf("%.4lf\n",F(mid)-y*mid);
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值