HDU 2899 Strange fuction

题目描述:

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

 

思路分析:一道数学题。。。极值是导数零点,求导,得 导数=f(x)-y,y是待输入常数,显然导数在0-100单调递增,且f(100)大于y,f(0)小于y,根据零点存在性定理可知,导数零点必然存在于(0,100)。令导数等于零,即f(x)==y,二分求解即可

 

直接三分应该也可以,有空补上三分代码

 

二分版

#include <stdlib.h>
#include <stdio.h>
#include <iostream>
#include <queue>
#include <algorithm>
#include <string.h>

using namespace std;

int t;
double y;

double F(double x){
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-y*x;
}

double f(double x){   //导数
    return pow(x,6)*42+pow(x,5)*48+pow(x,2)*21+x*10;
}

int main()
{
    scanf("%d",&t);

    while(t--){
        scanf("%lf",&y);

        double left=0,right=100;
        double mid;
        while(right-left>1e-6){
            mid=(left+right)/2;
            double t=f(mid);
            if(abs(t-y)<1e-4)break;
            else if(t>y) right=mid;
            else left = mid;
            //printf("%f %f %f %f\n",left,mid,right,t);
        }
        printf("%.4f\n",F(mid));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值