Face The Right Way

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input
Line 1: A single integer: N
Lines 2… N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.
Output
Line 1: Two space-separated integers: K and M
Sample Input
7
B
B
F
B
F
B
B
Sample Output
3 3
Hint
For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

大致的题意是这样的,一个农夫有一群牛,他想让所有牛都朝向正向,所以买了一台转牛机器,但是机器只能一次性转K个,题目给定牛的数量和方向,问最少的转牛的次数是多少。
这题的思路是这样的,我们从头开始转牛,检测到牛朝后则反转,但是要考虑到一次转K头牛,那么如何记录当此反转对后面K-1头牛的影响呢?我们可以用尺取法的思想定义一个数sum来记录当前牛前K-1头牛的总共的旋转次数,若旋转次数为奇数,说明当前牛已经被转成了反向,若sum为偶数,则可以忽略sum对当前牛的影响。
具体代码如下:
#include<iostream>
#include<memory>
#include<algorithm>
using namespace std;
int n;
int dir[5005];//记录牛的方向 0表示前,1表示后
int f[5005];//记录当前牛被翻转的次数
int calc(int k)
{
	memset(f, 0, sizeof(f));
	int ans = 0;
	int sum = 0;//保存k区间内前者对后者的影响
	for (int i = 0; i + k <= n; i++)
	{
		//计算区间[i,i+k-1]
		if ((dir[i] + sum) % 2 != 0)//sum是奇数的话说明自己已经被转成反向了,
		{
			ans++;
			f[i] = 1;
		}
		sum += f[i];
		if (i - k + 1 >= 0)//满k个了,尺取法思想 k等于3时,第4个数不会受到第1个数的影响
			sum -= f[i - k + 1];
	}
	for (int i = n - k + 1; i < n; i++)
	{
		if ((dir[i] + sum) % 2 != 0)
			return -1;//无解
		if (i - k + 1 >= 0)//继续尺取法
			sum -= f[i - k + 1];
	}
	return ans;
}
void solve()
{
	int k = 1, m = n;
	int t = 1;
	for (int i = 1; i <= n; i++)
	{
		k = i;
		int p = calc(k);
		if (p >= 0 && m > p)
		{
			m = p;
			t = k;
		}
	}
	printf("%d ", t);
	printf("%d\n", m);
}
int main()
{
	while (cin >> n)
	{
		memset(dir, 0, sizeof(dir));
		for (int i = 0; i < n; i++)
		{
			char a;
			cin >> a;
			if (a == 'F')
				dir[i] = 0;
			else
				dir[i] = 1;
		}
		solve();
	}
}
Recently, the renowned actor Zhang Songwen has sparked a fascinating phenomenon known as "two-way rejection", which has captured the attention of many and inspired the masses. The roots of this phenomenon are complex, with one of the fundamental causes being the fear of failure that plagues most of us. Rejection can instill a sense of inadequacy and a fear of being perceived as a failure, which can be challenging to overcome. However, the concept of "two-way rejection" teaches us that rejection is a natural part of life, and it's acceptable to reject and be rejected in return. This empowers us to recognize that life is not just about failures, but also about perseverance, and striving to achieve our aspirations, which may include fame and fortune. Despite the distractions we may encounter, the concept of "two-way rejection" reminds us to turn away from erroneous opportunities and remain steadfast in our principles and moral compass. While there are both advantages and drawbacks to this approach, "two-way rejection" ultimately inspires us to embrace rejection, learn from it, and emerge stronger and more self-assured. However, it is essential to distinguish between a sound and an unsound opportunity to avoid blindly rejecting the right ones. In conclusion, the concept of "two-way rejection" should be approached with discretion, but it can prove to be a valuable tool in enabling us to adhere to our goals and persevere through rejection. It teaches us to embrace rejection, learn from it, and move forward with confidence, ultimately empowering us to achieve our dreams and aspirations.结合双向拒绝进行内容补充
最新发布
05-10
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值