POJ 3276 Face The Right Way(反转问题)


Face The Right Way

Time Limit: 2000MS


Memory Limit: 65536K

Total Submissions: 3493


Accepted: 1614

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N 
Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)


题意:有n头牛排成一列,面朝前(F)或者面朝后(B)。约翰想让所有的牛都面朝前,他每次可以反转连续的k头牛。求为了让所有牛都面朝前需要最少反转的次数M和对应的最小连续长度K值。

题解:首先我们能想到的是从第一头牛开始遍历,把每头面朝后的和后面的k-1头牛都反转。增加m的值,在当前m的情况下枚举k看是否存在k值能使得所有牛都反转过去。 这样的算法时间复杂度为O(n^3),显然是超时的。

超时代码:

//超时代码 
#include<cstdio>
#include<cstring>
int a[5010],b[5010];
int main()
{
	int n,m,k,i,j,sign;
	char s[2];
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;++i)
		{
			scanf("%s",s);
			if(s[0]=='B')
				b[i]=1;
			if(s[0]=='F')
				b[i]=0;
		}
		m=1;
		while(1)
		{
			int cnt;
			for(k=1;k<=n;++k)
			{
				sign=1;
				cnt=0;
				memcpy(a,b,sizeof(b));//将数组b拷贝给数组a 
				for(i=0;i<=n-k;++i)
				{
					if(a[i]==1)
					{
						for(j=i;j<i+k;++j)
						{
							if(a[j]==1)
								a[j]=0;
							else if(a[j]==0)
								a[j]=1;
						}
						cnt++;
					}
					if(cnt==m)
						break;
				}
				for(i=0;i<n;++i)
				{
					if(a[i]==1)
					{
						sign=0;
						break;
					}
				}
				if(sign)
					break;
			}
			if(sign)
				break;
			else
				m++;
		}
		printf("%d %d\n",m,k);
	}
	return 0;
} 


我们来需找优化方法,用f[i]表示区间[i,k+i-1]是否进行了反转,是为1,否为0。 这样每头牛反转的次数是它前面k-1头牛中出现的面朝后的牛的个数和,用sum表示,如果sum+a[i]为奇数则表示这头牛面朝后方,f[i]就等于1,表示这头牛需要反转,这样对于每头牛的操作都缩到了O(1)的时间复杂度。 最后枚举k值,记录需要的最少反转次数和对应的最小的k。这样的算法时间复杂度为O(n^2)。  精华之处在于用f[i]和sum记录的反转次数。

代码如下:

#include<cstdio>
#include<cstring>
int a[5010];//牛的方向(0:F 1:B) 
int n,f[5010];//区间[i,i+k-1]是否进行反转 

int slove(int k)
{
	memset(f,0,sizeof(f));
	int ans=0;
	int sum=0,i;//sum记录f的和,即下一个牛被反转的次数 
	for(i=0;i+k<=n;++i)
	{
		if((a[i]+sum)%2!=0)
		{
			ans++;//记录反转的次数 
			f[i]=1;
		}
		sum+=f[i];
		if(i-k+1>=0)//对下一个牛造成反转影响的只是它前面k-1个牛 
			sum-=f[i-k+1];
	}
	for(i=n-k+1;i<n;++i)//检查剩下的牛是否有面朝后方的情况 
	{
		if((a[i]+sum)%2!=0)//表示当前牛面朝后方,已无法经行反转,无解 
			return -1; 
		if(i-k+1>=0)
			sum-=f[i-k+1];
	}
	return ans;
}

int main()
{
	int m,k,i;
	char s[2];
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;++i)
		{
			scanf("%s",s);
			if(s[0]=='F')
				a[i]=0;
			else
				a[i]=1;
		}
		int K=1,M=n;
		for(k=1;k<=n;++k)
		{
			m=slove(k);
			if(m>=0&&M>m)//更新m,k的值,确保是在m最小的1情况下,取得最小的k值 
			{
				M=m;
				K=k;
			}
		}
		printf("%d %d\n",K,M);
	}
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值