WOJ1013-Bracelet

Some beads are embedded in a bracelet, and each beads is carved with a lower case letter, as the follow figure shows:

If we read the letters in counter clockwise with different initial position, we may get different strings. The above example, we can read 6 strings:
acabdb
cabdba
abdbac
bdbaca
dbacab
bacabd
Sort these strings in lexical order, we obtain:
abdbac
acabdb
bacabd
bdbaca
cabdba
dbacab
What we need is the first string: abdbac.

输入格式

A string of lower case letters representing the letters carved on the bracelet (in counter clockwise order).
The length of the string is no more than 100.

输出格式

Output the first string of all the possible strings after sorting them in lexical order.

样例输入

acabdb
kkisverystupid

样例输出

abdbac
dkkisverystupi

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int Comp(const void*p1,const void*p2){
	return strcmp((char*)p1,(char*)p2);
}
int main(){
    char in[101];
    while(scanf("%s",in)!= EOF){
        int len = strlen(in);
        char out[101][101];
        for(int i=0; i<len; i++){
            for(int j=0; j<len; j++){
                out[i][j] = in[(j + i)%len];
            }
            out[i][len] = '\0';
        }
        qsort(out,len,sizeof(out[0]),Comp);
        printf("%s\n",out[0]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值