WOJ1406-Internet Service Providers

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through the channel and gets a profit that is directly proportional to the factor T * (C - T * N). The problem is to compute T_optim, the smallest value of T that maximizes the total profit the N ISPs can get from using the channel. Notice that N, C, T, and T_optim are integer numbers.

输入格式

Each data set corresponds to an instance of the problem above and contains two integral numbers - N and C - with values in the range from 0 to 10^9. The input data are separated by white spaces, are correct, and terminate with an end of file. For each data set the program computes the value of T_optim according to the problem instance that corresponds to the data set.

输出格式

The result is printed on the standard output from the beginning of a line. There must be no empty lines on the output. An example of input/output is shown below.

样例输入

1 0
0 1
4 3
2 8
3 27
25 1000000000

样例输出

0
0
0
2
4
20000000


#include<stdio.h>
int main() {
	int n,c,r;
	while(scanf("%d %d",&n,&c)!=EOF) {
		if(n==0 || c==0) printf("0\n");
		else {
			float result=(float)(c/2.0/n);
			r=result;
			if(result-r<=0.5) printf("%d\n",r);
			else printf("%d\n",r+1);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值