WOJ1034-Cut the Apple

On the way home, DragonFly has got an extraordinarily large apple. He would like to share it with his friends. Now he wants to get
as many pieces as possible with n cuts. But he cannot decide how to cut it, because the apple is rather delicious. Now he needs your help.

输入格式

Each line contains an integer n (0<= n <= 100000).
Input will be terminated by EOF.

输出格式

You should print the largest number of pieces by n cuts of each case .

样例输入

1
2
3

样例输出

2
4
8

N个平面可以把空间分成(n*n*n+5*n+6)/6份

#include<stdio.h>
#include<math.h>

int main()
{
    long long n;
    long long max;
    while(scanf("%lld",&n)!=EOF)
    {
        max=(n*n*n+5*n+6)/6;
        printf("%lld\n",max);
        }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值