WOJ1185-Apples

Little Ginger got an assignment from her teacher: how many ways are there to put 4 apples in 2 baskets. There are no differences between apples and baskets. It?s easy for Ginger to solve, since she can enumerate all the cases, which are {0, 4}, {1, 3} and {2, 2}.
How about we crank it up a notch? Now, there are M apples and N baskets, (N and M won?t exceed 100), how many ways are there?

输入格式

Multiple input cases! Two positive integers M and N in a single line for each case.

输出格式

Print the answer in a single line.

样例输入

6 4
3 2

样例输出

9
2

 预处理出所有的结果,直接查表即可。

#include<stdio.h>
int dp[101][101];
int main(){
	int i,j;
	for(i=0;i<101;i++)
	dp[0][i]=1;
	for(i=0;i<101;i++)
	dp[1][i]=1;
	for(i=2;i<101;i++)
	dp[i][0]=1;
	for(i=2;i<101;i++)
	dp[i][1]=1;
	for(i=2;i<101;i++)
	for(j=2;j<101;j++)
	if(i>=j) 
	dp[i][j]=dp[i-j][j]+dp[i][j-1];
	else
	dp[i][j]=dp[i][i]; 
	/*for(i=1;i<=10;i++){
		for(j=1;j<=10;j++)
		printf("%d ",dp[i][j]);
		printf("\n");
	}*/
	while(scanf("%d %d",&i,&j)==2){
		printf("%d\n",dp[i][j]);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值