WOJ1058-Exchange

While traveling at New York, Aftermath finds a new vending machine. This machine can only Accept three kinds of coins: 1$, 2$ and 3$.


However, he has only a cheque of N$. He has to enter a bank to exchange it for cash. Now he is interested in the problem: how many ways can
the bank exchanges the cheque for cash? But he is not smart enough to solve this problem. He asks you for help calculate the number of
different ways to exchange the cheque. The input is ended by 0.

输入格式

Given a cheque of N$(0<n<=10^9), The input is ended by 0.

输出格式

Calculate the number of different ways to exchange the cheque.

样例输入

1 
2
3
0

样例输出

1
2
3 

#include <stdio.h>
int main(){
    long long a,b,t,c;
    while(scanf("%lld",&t)==1&t!=0){
        c=0;      
        for(a=t/3;a>=0;a--){ 
            b=(t-a*3)/2+1; 
            c=c+b; 
        }
        printf("%lld\n",c);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值