WOJ1092-Pure numbers

A positive integer m is said to a pure number if and only if m can be expressed as q-th power of a prime p (q >= 1). 
Here your job is easy, for a given positive integer k, find the k-th pure number. 
 

输入格式

The input consists of multiple test cases. For each test case, it contains a positive integer k (k<5,000,000). Process to end of file.

输出格式

For each test case, output the k-th pure number in a single line. If the answer is larger than 5,000,000, just output -1.

样例输入

1
100
400000

样例输出

2
419
-1

计算出500W以内的质数和质数方幂的表,排序后查表即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int num[5000007];
int res[350000];
int main(){
	int i,j,sum=0,k;
	long long n;
	memset(num,0,sizeof(num));
	for(i=2;i<5000000;i++){
		if(num[i]==0){
			num[i]=1;
			res[sum]=i;
			sum++;
			n=i*i;
			for(j=i+i;j<5000000;j=j+i){
				num[j]=1;
				if(j==n){
					res[sum]=j;
					sum++;
					n=n*i;
				}
			}
		}
	}
	//printf("%d\n",sum);
	sort(res,res+sum);
	while(~scanf("%d",&k)){
		if(k<=348940)
		printf("%d\n",res[k-1]);
		else
		printf("-1\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值