WOJ1213-Area

Give you a simple polygon, the border is plumb or aclinic. your task is calculate the area of the polygon.

输入格式

first line is n(n≤100)。following N lines contains X,Y, the vertexs show as counter-clockwise. -200≤x,y≤200。

输出格式

print the total area.

样例输入

10
0 0
4 0
4 1
3 1
3 3
2 3
2 2
1 2
1 3
0 3

样例输出

9


#include<stdio.h>
#include<math.h>
int main(){
	int n,i,j;
	double sum;
    while(scanf("%d",&n)!=EOF){
        sum=0.0;
        double a[n][2];
        for(i=0;i<n;i++)
        for(j=0;j<2;j++)
        scanf("%lf",&a[i][j]);
        for(i=0;i<n-1;i++)
        sum+=(a[i][0]*a[i+1][1]-a[i+1][0]*a[i][1])/2.0;
        sum+=(a[n-1][0]*a[0][1]-a[0][0]*a[n-1][1])/2.0;
    	sum=fabs(sum);  
        printf("%d\n",(int)sum);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值