WOJ1110-Frame Stacking

Consider the following 5 picture frames placed on an 9 x 8 array. 

........ ........ ........ ........ .CCC.... 
EEEEEE.. ........ ........ ..BBBB.. .C.C.... 
E....E.. DDDDDD.. ........ ..B..B.. .C.C.... 
E....E.. D....D.. ........ ..B..B.. .CCC.... 
E....E.. D....D.. ....AAAA ..B..B.. ........ 
E....E.. D....D.. ....A..A ..BBBB.. ........ 
E....E.. DDDDDD.. ....A..A ........ ........ 
E....E.. ........ ....AAAA ........ ........ 
EEEEEE.. ........ ........ ........ ........ 
1 2 3 4 5 


Now place them on top of one another starting with 1 at the bottom and ending up with 5 on top. If any part of a frame covers another 
it hides that part of the frame below. 

Viewing the stack of 5 frames we see the following. 

.CCC.... 
ECBCBB.. 
DCBCDB.. 
DCCC.B.. 
D.B.ABAA 
D.BBBB.A 
DDDDAD.A 
E...AAAA 
EEEEEE.. 


In what order are the frames stacked from bottom to top? The answer is EDABC. 

Your problem is to determine the order in which the frames are stacked from bottom to top given a picture of the stacked frames. 
Here are the rules: 

1. The width of the frame is always exactly 1 character and the sides are never shorter than 3 characters. 

2. It is possible to see at least one part of each of the four sides of a frame. A corner shows two sides. 

3. The frames will be lettered with capital letters, and no two frames will be assigned the same letter.

输入格式

Each input block contains the height, h (h<=30) on the first line and the width w (w<=30) on the second. A picture of the stacked frames is
then given as h strings with w characters each.
Your input may contain multiple blocks of the format described above, without any blank lines in between. All blocks in the input must be
processed sequentially.The file is terminated by two zeros in place of the dimensions.

输出格式

Write the solution to the standard output. Give the letters of the frames in the order they were stacked from bottom to top. If there are multiple
possibilities for an ordering, list all such possibilities in alphabetical order, each one on a separate line. There will always be at least one legal
ordering for each input block. List the output for all blocks in the input sequentially, without any blank lines (not even between blocks).

样例输入

9
8
.CCC....
ECBCBB..
DCBCDB..
DCCC.B..
D.B.ABAA
D.BBBB.A
DDDDAD.A
E...AAAA
EEEEEE..
0
0

样例输出

EDABC
因为每个字母在四个方向都会出现至少一个,所以我们扫描一遍图可以知道每个字母的矩阵的范围,那么扫描每个字母的矩阵边缘,如果发现这个矩阵中有字母不属于这个矩阵,那么把覆盖的字母到当前字母连一条边,最后构造出来一个字母之间的DAG图,top排序出所有的情况输出即可。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 400000+10;

struct Rect{
	Rect(int ll=-1 ,int rr=-1,int tt=-1,int bb=-1)
		: l(ll) , r(rr) , t(tt) , b(bb) { }
	int l,t,r,b;
}frame[30];

char block[31][31];
bool vis[30];
char ans[maxn][30];
int top,h,w,Index=0;

int cmp(const void * s1 , const void * s2)
{
	return strcmp((char*)s1,(char*)s2);
}
bool find_rect(char ch)
{
	int l=100,t=100,b=-1,r=-1;
	for(int i=0;i<h;++i)
	{
		for(int j = 0 ; j < w ; ++j) 
		if(block[i][j]==ch)
		{
			if (l > j) l = j;
			if (t > i) t = i;
			if (b < i) b = i;
			if (r < j) r = j;
		}//确定矩形的位置,左上和右下 
	}
	if (b==-1) return false;//没有对应字母的矩形 
	frame[ch-'A']=Rect(l,r,t,b);
	return true;
}

bool can_put(char ch)
{
	if (frame[ch-'A'].l==-1) return false;
	int r = frame[ch-'A'].t;
	int c = frame[ch-'A'].l;
	while (c < frame[ch-'A'].r) 
	{
		if (block[r][c]==ch || vis[block[r][c]-'A']) ++c;
		else return false;
	}
	while (r < frame[ch-'A'].b)
	{
		if (block[r][c]==ch || vis[block[r][c]-'A']) ++r;
		else return false;
	}
	while (c > frame[ch-'A'].l)
	{
		if (block[r][c]==ch || vis[block[r][c]-'A']) --c;
		else return false;
	}
	while (r > frame[ch-'A'].t)
	{
		if (block[r][c]==ch || vis[block[r][c]-'A']) --r;
		else return false;
	}
	return true;
}

void dfs(int rest)
{
	if (rest==0)
	{
		ans[top++][Index] = '\0';
		strcpy(ans[top],ans[top-1]);
		return;
	}
	for(char ch='A';ch<='Z';++ch) 
	if(!vis[ch-'A']&&can_put(ch))
	{
		ans[top][Index++] = ch;
		vis[ch-'A'] = true;
		dfs(rest-1);
		--Index;
		vis[ch-'A'] = false;
	}
}

void solve()
{
	int cnt = 0;
	for (char ch='A';ch<='Z';ch++) 	if(find_rect(ch)) ++cnt;
	dfs(cnt);
	char buffer[30];
	for (int i=0;i<top;++i)
	{
		strcpy(buffer,ans[i]);
		for (int j=0;j<cnt;++j) ans[i][j]=buffer[cnt-1-j];//倒序 
	}
	qsort(ans,top,sizeof(ans[0]),cmp);
	for (int i=0;i<top;++i) printf("%s\n",ans[i]);
}
int main(){
	while(scanf("%d %d",&h,&w)==2&&(h!=0&&w!=0)){
		for(int i=0;i<h;++i) scanf("%s",block[i]);
		for(int i=0;i<26;++i) frame[i]=Rect();
		top = 0;
		memset(vis,false,sizeof(vis));
		solve();
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值