poj 1128 Frame Stacking(拓扑字典序)

Frame Stacking
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4112 Accepted: 1380

Description

Consider the following 5 picture frames placed on an 9 x 8 array. 
........ ........ ........ ........ .CCC....

EEEEEE.. ........ ........ ..BBBB.. .C.C....

E....E.. DDDDDD.. ........ ..B..B.. .C.C....

E....E.. D....D.. ........ ..B..B.. .CCC....

E....E.. D....D.. ....AAAA ..B..B.. ........

E....E.. D....D.. ....A..A ..BBBB.. ........

E....E.. DDDDDD.. ....A..A ........ ........

E....E.. ........ ....AAAA ........ ........

EEEEEE.. ........ ........ ........ ........

    1        2        3        4        5   

Now place them on top of one another starting with 1 at the bottom and ending up with 5 on top. If any part of a frame covers another it hides that part of the frame below. 

Viewing the stack of 5 frames we see the following. 
.CCC....

ECBCBB..

DCBCDB..

DCCC.B..

D.B.ABAA

D.BBBB.A

DDDDAD.A

E...AAAA

EEEEEE..






In what order are the frames stacked from bottom to top? The answer is EDABC. 

Your problem is to determine the order in which the frames are stacked from bottom to top given a picture of the stacked frames. Here are the rules: 

1. The width of the frame is always exactly 1 character and the sides are never shorter than 3 characters. 

2. It is possible to see at least one part of each of the four sides of a frame. A corner shows two sides. 

3. The frames will be lettered with capital letters, and no two frames will be assigned the same letter.

Input

Each input block contains the height, h (h<=30) on the first line and the width w (w<=30) on the second. A picture of the stacked frames is then given as h strings with w characters each. 
Your input may contain multiple blocks of the format described above, without any blank lines in between. All blocks in the input must be processed sequentially.

Output

Write the solution to the standard output. Give the letters of the frames in the order they were stacked from bottom to top. If there are multiple possibilities for an ordering, list all such possibilities in alphabetical order, each one on a separate line. There will always be at least one legal ordering for each input block. List the output for all blocks in the input sequentially, without any blank lines (not even between blocks).

Sample Input

9
8
.CCC....
ECBCBB..
DCBCDB..
DCCC.B..
D.B.ABAA
D.BBBB.A
DDDDAD.A
E...AAAA
EEEEEE..

Sample Output

EDABC

Source

题意:ASC码顺序排出可能的像框排列顺序

分析:建图->dfs,建图时扫描每个相框的边界有其他字母则建一条边(不要有重边),统计每个节点的入度,然后dfs每次取一入度为零的节点,并将该节点的子节点入度减一,重复dfs此动作,记得dfs后还原入度

这题吧看着像是拓补,但拓扑还真搞不定,解法只有拓扑的建边部分再加dfs

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#include <algorithm>
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define LL long long
#define MAXN 55
#define MAXM 2005
using namespace std;
char g[35][35];
int cnt,ecnt,first[MAXN],h[MAXN],minx[MAXN],maxx[MAXN],miny[MAXN],maxy[MAXN];
int nex[MAXM],v[MAXM];
bool gv[MAXN][MAXN];

void add_(int a,int b)
{
    v[ecnt]=b;
    nex[ecnt]=first[a];
    first[a]=ecnt++;
}
void slove()
{
    int i,j,k;cnt=0;
    memset(h,-1,sizeof h);//入度
    memset(gv,0,sizeof gv);
    for(k=0;k<26;k++)
    if(minx[k]!=30)
    {
        if(h[k]==-1)h[k]=0;
        cnt++;
        for(i=minx[k];i<=maxx[k];i++)
            for(j=miny[k];j<=maxy[k];j=i!=minx[k]&&i!=maxx[k]&&j==miny[k]?maxy[k]:j+1)
            {
                if(g[i][j]=='.'||g[i][j]=='A'+k)continue;
                int tmp=g[i][j]-'A';
                if(!gv[k][tmp])
                {
                     add_(k,tmp);
                     gv[k][tmp]=1;
                    if(h[tmp]==-1)h[tmp]=1;
                    else h[tmp]++;
                }
            }
    }
}

void dfs(int place,string ans)
{
    int i,e;
    if(place==cnt)
    {
        cout<<ans<<endl;
        return ;
    }
    for(i=0;i<26;i++)
    if(!h[i])
    {
        h[i]=-1;
        for(e=first[i];~e;e=nex[e])
            h[v[e]]--;
        char c='A'+i;
        dfs(place+1,ans+c);
        h[i]=0;
        for(e=first[i];~e;e=nex[e])
            h[v[e]]++;
    }
}

int main()
{
    int n,m,i,j,k;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=0;i<n;i++)
            scanf("%s",g[i]);
        memset(first,-1,sizeof first);
        ecnt=0;
        for(i=0;i<26;i++)
        {
            maxx[i]=maxy[i]=0;
            minx[i]=miny[i]=30;
        }
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            if(g[i][j]!='.')
            {
                int tmp=g[i][j]-'A';
                maxx[tmp]=max(maxx[tmp],i);
                minx[tmp]=min(minx[tmp],i);
                maxy[tmp]=max(maxy[tmp],j);
                miny[tmp]=min(miny[tmp],j);
            }
        slove();
        string ans="";
        dfs(0,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值