WOJ1154-A Simple Task

Alice's QQ is lost because she set a very simple password ?abcdefg?, her friend Bob
tell her that a password like ?abcdefg? is too easy to guess, a good password is suggest
to be at least 6 bytes long, and better to include upper case letters, lower case letters,
digitals, and symbols (like '#', '_', '$'). But Alice is a lazy girl, she doesn't like to
remember a password which is too complex, e.g., "_a#9Bx", so she decides to do some modification
on her original password that is change letters at even position to upper case.
Alice has many passwords used in different places, so she asks you to change them as the
rule she decided.

输入格式

There are multiple test cases. Each case is a single line which has a string only contains lower case letters, but no longer than 50 letters.
Input is end with a line only contains?#" and should not be processed by your program.

输出格式

For each test case, output the new password on a single line in the format as indicated.

样例输入

abcdefg
alice
bob
#

样例输出

Case 1: aBcDeFg
Case 2: aLiCe
Case 3: bOb

简单题

#include<stdio.h>
char pass[55];
int main(){
	int i,n=1;
	while(scanf("%s",&pass)){
		if(pass[0]=='#')
		break;
		for(i=0;pass[i]!='\0';i++){
			if(i%2==1)
			pass[i]=pass[i]-'a'+'A';
		}
		printf("Case %d: %s\n",n++,pass);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值