WOJ1225-Catch That Cow

Farmer John has been informed of the location of a fugitive cow and
wants to catch her immediately. He starts at a point N (0 <= N <=
100,000) on a number line and the cow is at a point K (0 <= K <=
100,000) on the same number line. Farmer John has two modes of
transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X-1 or
X+1 in a single minute

* Teleporting: FJ can move from any point X to the point 2*X
in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long
does it take for Farmer John to retrieve it?

输入格式

  • Line 1: Two space-separated integers: N and K

输出格式

  • Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

样例输入

5 17

样例输出

4

提示

INPUT DETAILS:

Farmer John starts at point 5 and the fugitive cow is at point 17.
OUTPUT DETAILS:

The fastest way for Farmer John to reach the fugitive cow is to
move along the following path: 5-10-9-18-17, which takes 4 minutes. 


//广搜,用f[i]表示到I点的最短时间,每次f[u]+1<f[v]时将V加入队列
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int N,K,f[100002];
queue<int> q;
int main() {
	while(scanf("%d %d",&N,&K)==2) {
		memset(f,0x7f,sizeof(f));
		q.push(N);
		f[N]=0;
		while (q.size()) {
			if (q.front()*2<=100000&&f[q.front()*2]>f[q.front()]+1) {
				q.push(q.front()*2);
				f[q.front()*2]=f[q.front()]+1;
				if(q.front()*2==K)break;
			}
			if (q.front()+1<=100000&&f[q.front()+1]>f[q.front()]+1) {
				q.push(q.front()+1);
				f[q.front()+1]=f[q.front()]+1;
				if(q.front()+1==K)break;
			}
			if (q.front()-1>=0&&f[q.front()-1]>f[q.front()]+1) {
				q.push(q.front()-1);
				f[q.front()-1]=f[q.front()]+1;
				if(q.front()-1==K)break;
			}
			q.pop();
		}
		printf("%d\n",f[K]);
	}
	return 0;
}



//C++98
#include<iostream>
#include<cstdio>
#define MAX 100005
using namespace std;
int font[2*MAX] , hash[2*MAX] ;  //定义一个是走的步数hash, 一个是标记记录所走过的路
int n,k;
int has( int i ) {          //判断是否越界
	if( i >= 2*MAX || i< 0 || hash[i] )
		return 0 ;
	else  return 1 ;
}
int BFS(int n,int k) {
	if( n==k ) return 0 ;
	int X, first=0 , last = 0 ;
	font[first++] = n ;    //把开始的地点赋给数组
	while( last < first ) {
		X = font[last++] ; //当前步所在的地方
		if( X-1 == k || X+1 == k || X*2== k ) //找到目标退出
			return hash[X]+1 ;
		if( has( X-1 ) )           //分三种情况搜索
			hash[X-1] = hash[X]+1 , font[first++] = X-1 ;
		if( has( X+1 ) )
			hash[X+1] = hash[X]+1 , font[first++] = X+1 ;
		if( has( X*2 ) )
			hash[X*2] = hash[X]+1 , font[first++] = X*2 ;
	}
	return -1 ;
}
int main(  ) {
	while( scanf("%d%d" ,&n , &k )==2 ) {
		for( int i=0 ; i< MAX*2 ; i++ )
			hash[i] = 0 ;
		cout<<BFS( n , k )<<endl ;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值