Catch That Cow
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers:
N and
K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意:人在N的位置,牛在K的位置,人有三种前进方式,+1、-1、*2,求人找到牛的最少的步数
#include"queue"
#include"cstdio"
#include"cstring"
#include"iostream"
#include"algorithm"
using namespace std;
#define MAXN 100000
struct node
{
int loc,t;
};
int st,en;
bool vis[MAXN + 5];
queue < node > q;
int bfs(int st)
{
while(!q.empty())
{
q.pop();
}
node a;
a.loc = st;
a.t = 0;
vis[a.loc] = true;
q.push(a);
while(!q.empty())
{
node b = q.front();
q.pop();
if(b.loc == en)
{
return b.t;
}
int l;
l = b.loc + 1; //情况1,前进一步
if(l > 0 && l < MAXN && !vis[l])
{
node c;
c.loc = l;
c.t = b.t + 1;
vis[l] = true;
q.push(c);
}
l = b.loc - 1; //情况2,后退一步
if(l >= 0 && l <= MAXN && !vis[l])
{//因为是后退,所以l可以等于0,之前写的>0,那么1,0这组样例就会出错
node c;
c.loc = l;
c.t = b.t + 1;
vis[l] = true;
q.push(c);
}
l = b.loc << 1;
if(l >= 0 && l <= MAXN && !vis[l]) //情况3,*2
{
node c;
c.loc = l;
c.t = b.t + 1;
vis[l] = true;
q.push(c);
}
}
}
int main()
{
while(~scanf("%d%d",&st,&en))
{
memset(vis,false,sizeof(vis)); //BFS被访问过的就不会再次被访问,需要标记
printf("%d\n",bfs(st));
}
return 0;
}