hdu 3232 Crossing Rivers (数学期望)

Crossing Rivers

                                                                                     Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them.

Fortunately, there is one "automatic" boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You're so slim that carrying you does not change the speed of any boat.

Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the  expected time to reach B from A? Your walking speed is always 1.

To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is  uniformly chosenfrom interval [0,  L], and the boat is equally like to be moving left or right, if it’s not precisely at the river bank.
 

Input
There will be at most 10 test cases. Each case begins with two integers  n and  D, where  n (0 <=  n <= 10) is the number of rivers between A and B,  D (1 <=  D <= 1000) is the distance from A to B. Each of the following  n lines describes a river with 3 integers:  p, L and  v (0 <=  p <  D, 0 <  L <=  D, 1 <=  v <= 100).  p is the distance from A to the left bank of this river,  L is the length of this river,  v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don’t overlap. The last test case is followed by  n=D=0, which should not be processed.
 

Output
For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.

Print a blank line after the output of each test case.
 

Sample Input
  
  
1 1 0 1 2 0 1 0 0
 

Sample Output
  
  
Case 1: 1.000 Case 2: 1.000
 
题目大意:A、B两点之间距离为D,并且在A、B之间有n条河,每条河上有一条自动船。船的宽度为L,把船看成一个点时,则它在第0时刻的位置是任意的,并且向两岸划动的可能性也是相同的。已知步行的速度为1,船的速度为v,每条河与A点的距离为P,求A到B花费的时间是多少。

分析:由题意不难得出,船在0时刻在河上的位置满足均匀分布,那么由均匀分布我们可知它的数学期望E = L/2。船向左岸划的概率等于向右岸划的概率为1/2,因为人只有通过船到左岸上船,再向右岸划动,才能过河。所以当船向左岸划的时候,那它到达左岸的期望时间T1 = L/2 * 1/2 / v;当船向右岸划,那它到达的左岸的期望时间T2 = (L/2 + L) * 1 / 2 / v;最后再从左岸到右岸的时间为T3 = L / v;所以过河的总期望时间为T = T1 + T2 + T3 = 2L / v;
#include<stdio.h>
int main()
{
    int n, i, cas = 0, d, p, l, v;
    while(~scanf("%d%d",&n,&d), n+d)
    {
        double ans = d*1.0;
        for(i = 0; i < n; i++)
        {
            scanf("%d%d%d",&p, &l, &v);
            ans -= l;  //减去不过这条河时所用的时间
            ans += 2.0*l / v; //加上过河时间
        }
        printf("Case %d: %.3lf\n\n",++cas, ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值