POJ 1837 Balance(动态规划之背包问题)

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11436 Accepted: 7130

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

题意:一个天平上有C个挂钩,第i个挂钩的位置为C[i],C[i] < 0表示该挂钩在原点的左边,C[i] > 0表示该挂钩在原点的右边;然后给出G个钩码的重量,问有多少种挂法使得天平保持平衡。


分析:当天平平衡时,每向天平上挂一个钩码,天平的状态就会改变,而这个状态可以由若干前一状态获得

首先定义一个平衡度j的概念

当平衡度j=0时,说明天枰达到平衡,j>0,说明天枰倾向右边(x轴右半轴),j<0则相反

那么此时可以把平衡度j看做衡量当前天枰状态的一个值

因此可以定义一个 状态数组dp[i][j],意为在挂满前i个钩码时,平衡度为j的挂法的数量。

由于距离L[i]的范围是-15~15,钩码重量的范围是w[i]是1~25,钩码数量最大是20

因此最极端的平衡度是所有物体都挂在最远端,因此平衡度最大值为j=15*20*25=7500。原则上就应该有dp[ 1~20 ][-7500 ~ 7500 ]。

因此为了不让下标出现负数,做一个处理,使得数组开为 dp[1~20][0~15000],令7500对应0,则当j=7500时天枰为平衡状态。

/*
    dp[i][j]表示用了前i个钩码,天平两端的差值(右端 - 左端)为j时的方案数。
    极端情况为所有钩码全部挂在左端的最左边位置,根据题目数据可知此时差值最大为
    0 - 15 * 25 * 20 = -7500,所以要加上一个偏移量,用7500对应0,假设钩码数量为G,
    则最终答案为dp[G][7500]。
    转移方程:dp[i][j + w[i] * l[k]] = Sigma(dp[i-1][j])。
    k为第k个挂钩位置
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int dp[21][15005];
int l[21], w[21];

int main() {
    int C, G;
    while(~scanf("%d%d", &C, &G)) {
        for(int i = 1; i <= C; i++)
            scanf("%d", &l[i]);
        for(int i = 1; i <= G; i++)
            scanf("%d", &w[i]);
        memset(dp, 0, sizeof(dp));  //达到每个状态的方法数初始化为0
        dp[0][7500] = 1; // 0对应7500,挂上前0个钩码后,天枰达到平衡状态7500的方法有1个,就是两端都不挂
        for(int i = 1; i <= G; i++) {
            for(int j = 0; j <= 15000; j++) {
                if(dp[i-1][j]) { // 当放入i-1个钩码时状态j已经出现且被统计过方法数,则直接使用统计结果,否则忽略当前状态j
                    for(int k = 1; k <= C; k++) {
                        dp[i][j + w[i] * l[k]] += dp[i - 1][j];
                    }
                }
            }
        }
        printf("%d\n", dp[G][7500]);
    }
    return 0;
}




  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值