hdu 2368 Alfredo's Pizza Restaurant

Alfredo's Pizza Restaurant

                                                                          Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Other)


Problem Description
Traditionally after the Local Contest, judges and contestants go to their favourite restaurant, Alfredos Pizza Restaurant. The contestants are really hungry after trying hard for five hours. To get their pizza as quickly as possible, they just decided to order one big pizza for all instead of several small ones. They wonder whether it is possible to put the big rectangular pizza on the surface of the round table such that it does not overhang the border of the table. Write a program that helps them!
 

Input
The input file contains several test cases. Each test case starts with an integer number r, the radius of the surface of the round table the contestants are sitting at. Input is terminated by r=0. Otherwise, 1 ≤ r ≤ 1000. Then follow 2 integer numbers w and l specifying the width and the length of the pizza, 1 ≤ w ≤ l ≤ 1000. 
 

Output
Output for each test case whether the ordered pizza will fit on the table or not. Adhere to the format shown in the sample output. A pizza which just touches the border of the table without intersecting it is considered fitting on the table, see example 3 for clarification. 
 

Sample Input
  
  
38 40 60 35 20 70 50 60 80 0
 

Sample Output
  
  
Pizza 1 fits on the table. Pizza 2 does not fit on the table. Pizza 3 fits on the table.
题目意思:给出桌子的半径和Pizza的长和宽,问Pizza能否放在这个桌子上而不会越过桌子边缘。将Pizza看做一个矩形,只要比较矩形的对角线和桌子的直径大小即可。注意数据类型。
#include<stdio.h>
#include<math.h>
int main()
{
    float w,l,d,r;
    int i=1;
    while(scanf("%f",&r)!=EOF)
    {
        if(r==0)
            break;
        scanf("%f%f",&w,&l);
        d=sqrt(w*w+l*l);  //对角线长
        if(d<=r*2)
            printf("Pizza %d fits on the table.\n",i++);
        else
            printf("Pizza %d does not fit on the table.\n",i++);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值