UVA 10465 - Homer Simpson 贪心

27 篇文章 0 订阅
27 篇文章 0 订阅
                                        Homer Simpson

Time Limit: 3 seconds
Memory Limit: 32 MB

Homer Simpson, a very smart guy, likes eating Krusty-burgers. It takes Homer m minutes to eat a Krusty- burger. However, there�s a new type of burger in Apu�s Kwik-e-Mart. Homer likes those too. It takes him n minutes to eat one of these burgers. Given t minutes, you have to find out the maximum number of burgers Homer can eat without wasting any time. If he must waste time, he can have beer.

Input

Input consists of several test cases. Each test case consists of three integers m, n, t (0 < m,n,t < 10000). Input is terminated by EOF.

Output

For each test case, print in a single line the maximum number of burgers Homer can eat without having beer. If homer must have beer, then also print the time he gets for drinking, separated by a single space. It is preferable that Homer drinks as little beer as possible.

Sample Input

3 5 54
3 5 55

Sample Output

18
17
题意:尽量用完时间t,求出最多吃多少个汉堡;如果实在用不完,再输出喝啤酒的时间。
#include<stdio.h>
#include<string.h>
int main()
{
	int m,n,t,max,i;
	while(~scanf("%d%d%d",&m,&n,&t))
	{
		if(m>n) /*保证m>n*/
		{int temp=m;m=n;n=temp;}
		max=t/m; /*最多的数量*/
		int beer_time=t-max*m; /*喝啤酒的时间*/
		if(beer_time==0)
		{
			printf("%d\n",max);
			continue;
		}
		for(i=1;i<=t/n;i++) 
		{
			int temp_max=(t-n*i)/m+i;
			int temp_beer_time=t-((temp_max-i)*m+i*n);
            if(temp_beer_time>=0&&temp_beer_time<beer_time)
			{
				max=temp_max;
				beer_time=temp_beer_time;
			}
			if(temp_beer_time==0)
				break;
		}
		printf("%d",max);
		if(beer_time!=0)
			printf(" %d",beer_time);
		printf("\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值