Temple of the bone - 九度 OJ 1461

Temple of the bone - 九度 OJ 1461

题目

时间限制:1 秒 内存限制:32 兆 特殊判题:否
题目描述:
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to
get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
输入:
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.
The input is terminated with three 0’s. This test case is not to be processed.
输出:
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
样例输入:
4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0
样例输出:
NO
YES

题目大意:有一个 N*M 的迷宫,包括起点 S,终点 D,墙 X,和地面,0秒时主人公从 S 出发,每秒能走到四个与其相邻的位置中的一个,且每个位置被行走之后都不能再次走入,问是否存在这样一条路径使主人公在 T 秒时刚好走到 D。

在这个问题中,题面不再要求我们求解最优解,而是转而需要我们判定是否存在一条符合条件的路径,所以使用深度优先搜索来达到这个目的。确定状态三元组(x,y,t),(x,y)为当前点坐标,t 为从起点走到该点所需的时间。我们需要的目标状态为(dx,dy,T),其中(dx,dy)为 D 所在点的坐标,T 为所需的时间。初始状态为(sx,sy,0),其中(sx,sy)为 S 所在点的坐标。

同样的,在深度优先搜索中也需要剪枝,我们同样不去理睬被判定不可能存在所需状态的子树,以期能够减少所需遍历的状态个数,避免不必要的超时。这里注意到,主人公每走一步时,其所在位置坐标中,只有一个坐标分量发生增一或者减一的改变,那么两个坐标分量和的奇偶性将发生变化。这样,当主人公走过奇数步时,其所在位置坐标和的奇偶性必与原始位置不同;而走过偶数步时,其坐标和的奇偶性与起点保持不变。若起点的坐标和的奇偶性和终点的坐标和不同,但是需要经过偶数秒使其刚好达到,显然的这是不可能的,于是我们直接判定这种情况下,整棵解答树中都不可能存在我们所需的状态,跳过搜索部分,直接输出 NO。

#include <stdio.h>

char maze[8][8];//保存地图信息
int n,m,t;//地图大小为n*m,从起点到终点能否恰好t秒
bool success;//能否找到所需状态标记
int go[][2]={
    1,0,
    -1,0,
    0,1,
    0,-1
};//四个方向行走坐标差

void DFS(int x,int y,int time){
    //递归形式的深度优先搜索
    for(int i=0;i<4;i++){
        //枚举四个相邻位置
        int nx=x+go[i][0];
        int ny=y+go[i][1];//计算其坐标
        if(nx<1 || nx>n || ny<1 || ny>m)continue;
        //若坐标在地图外则跳过

        if(maze[nx][ny]=='X')continue;//若该位置为墙,跳过
        if(maze[nx][ny]=='D'){
            //若该位置为门
            if(time+1 == t){
                //若所用时间恰好为t
                success=true;//搜索成功
                return;//返回
            }
            else continue;
            //否则该状态的后续状态不可能为答案
            //(经过的点不能再经过),跳过
        }
        maze[nx][ny]='X';
        //该状态扩展而来的后续状态中,该位置都不能被经过,
        //直接修改该位置为墙

        DFS(nx,ny,time+1);//递归扩展该状态,所用时间递增
        maze[nx][ny]='.';
        //若后续状态全部遍历完毕,则退回上层状态,
        //将因为要搜索其后续状态而改成墙的位置,改回普通位置

        if(success)return;//假如已经成功,则直接返回,停止搜索
    }
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&t)!=EOF){
        if(n==0 && m==0 && t==0)break;

        for(int i=1;i<=n;i++){
            scanf("%s",maze[i]+1);
        }

        success=false;//初始化成功标记
        int sx,sy;
        for(int i=1;i<=n;i++){
            //寻找D的位置坐标
            for(int j=1;j<=m;j++){
                if(maze[i][j]=='D'){
                    sx=i;
                    sy=j;
                }
            }
        }

        for(int i=1;i<=n;i++){
            //寻找初始状态
            for(int j=1;j<=m;j++){
                if(maze[i][j]=='S' && (i+j)%2==((sx+sy)%2+t%2)%2){
                    //找到S点后,先判断S与D的奇偶性关系,
                    //是否和t符合,即符合上式,若不符合直接跳过搜索
                    maze[i][j]='X';//将起点标记为墙
                    DFS(i,j,0);//递归扩展初始状态
                }
            }
        }
        puts(success==true ? "YES" : "NO");
        //若success为真,则输出yes
    }
    return 0;
}

如该代码所示,我们用递归函数完成深度优先搜索。深度优先搜索的各要素如下:
搜索空间:广度优先搜索相同,依旧是所有的状态。
搜索目的:查找一个可以表示原问题解的状态。
搜索方法:在解答树上进行先序遍历。

总结深度优先搜索的相关特点:
其查找空间和查找目的均与广度优先搜索保持一致,与广度优先搜索有较大不同的是它的查找方式。深度优先搜索对状态的查找采用了立即扩展新得到的状态的方法,我们常使用递归函数来完成这一功能。正是由于采用这样的扩展方法,由它搜索而来的解不再拥有最优解的特性,所以我们常用它来判断解是否存在的存在性判定。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值