贪心专题 HDU

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77018    Accepted Submission(s): 26456


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
 

Source
 

Recommend
JGShining
 
题意,这里有一个奇葩的老鼠和一群奇葩的猫,老鼠喜欢吃javabean,但是他手里只有猫咪爱 吃的食物。每一个猫咪看守一部分javabean,允许老鼠拿他爱吃的食物来换,多少食物换多javabean,不同的猫咪要求的食物及提供的javabean不一样,让你算算老鼠最大可以换多少javabean。
贪心题,老鼠肯定是先换取最实惠的,他那么聪明
ac代码(提交使用G++的时候,要记得double输出使用%f)

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>

using namespace std;

struct node{
    int jav,foo;
    double ave;
}nn[1005];

bool cmp(node x,node y){
    return x.ave > y.ave;
}
int m,n;

int main()
{


    while(~scanf("%d%d",&m,&n),(m!=-1 || n!=-1)){

        for(int i=1;i<=n;i++){
            scanf("%d%d",&nn[i].jav,&nn[i].foo);
            nn[i].ave=nn[i].jav*1.0/nn[i].foo;
        }
        sort(nn+1,nn+1+n,cmp);
        double ans=0;
        for(int i=1;i<=n;i++){
            if(m > nn[i].foo){
                ans+=nn[i].jav;
                m=m-nn[i].foo;
            }
            else if(m > 0){
                ans+=nn[i].ave*m;
                break;
            }
            else
                break;
        }


        printf("%.3f\n",ans);
    }

    return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值