HDU 1051 Wooden Sticks 贪心+暴力

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21436    Accepted Submission(s): 8650


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1052  1045  1053  1789  1257 
 

题意:切割木头,只有提高切割机需要花费时间,求最少花费的时间

有两个要求:

1:第一块必须花费一分钟

2:如果马上要切割的一块比上一块长度长且重量大,就无需调整机器,其他都需要花费一分钟去调整机器。


分析:

    先贪心排序,按长度短的排序,长度相同的,按重量小的在前面。

    然后去暴力搜索,每一个木头切割的顺序不一定是排完序之后的,在家一层循环,去搜索,每次用x、y记录上一个被搜索到的值,不会超时,因为已经排序优化了。


ac代码:

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
#define ll long long

using namespace std;
const int MAX=5000+5;

struct node{
	int x,y;
}nn[MAX];
int vis[MAX];
int t,n;

bool cmp(node a,node b){
	if(a.x == a.x)
		return a.y < b.y;
	return a.x < b.x;
}

int main()
{
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%d%d",&nn[i].x,&nn[i].y);
		}
		sort(nn,nn+n,cmp);
		ll cnt=0;
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++){
			if(vis[i])
				continue ;
			
			int y=nn[i].y;
			int x=nn[i].x;
			for(int j=i+1;j<n;j++){
				if(!vis[j] &&nn[j].x >= x && y <= nn[j].y){
					vis[j]=1;
					y=nn[j].y;
					x=nn[j].x;
				}
			}
			vis[i]=1;
			cnt++;
		}
		printf("%lld\n",cnt);
	}
	
	
	
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值