HDU 1251 统计难题

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 44944    Accepted Submission(s): 16076


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 

Author
Ignatius.L
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1075  1247  1671  1298  1800 
 


字典树经典问题

不过用指针提交得慎重用G++和C++指针的大小不一样


ac代码(C++)

#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#define ull unsigned long long

using namespace std;

struct Trie{
	Trie* next[26];
	int num;
	Trie(){
		for(int i=0;i<26;i++){
			next[i]=NULL;
		}
		num=0; 
	}
};

Trie root;

void Insert(char word[]){
	Trie *p=&root;
	int i;
	for(i=0;word[i];i++){
		if(p->next[word[i]-'a'] == NULL)
			p->next[word[i]-'a'] = new Trie;
		p = p->next[word[i] - 'a'];
		p->num++;
	}
}

int Find1(char word[]){
	Trie *p=&root;
	int i;
	for(int i=0;word[i];i++){
		if(p->next[word[i] - 'a'] == NULL)
			return 0;
		p = p ->next[word[i] - 'a'];
	}
	return p->num;
}

int main(){
	
	char word[11];
	while(gets(word) && word[0]){
		if(strlen(word) == 0)
			break ;
		Insert(word);
	}
	
	while(scanf("%s",word) != EOF){
		printf("%d\n",Find1(word));
	}
	
	
	
	return 0;
}


数组实现,(一直没想好怎么确定数组大小,内存会爆多少)

my ugly code

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
using namespace std;
int tire[1000010][26];
int num[1000010];
int pos=1;

void Insert(char word[]){

    int c=0;

    for(int i=0;word[i];i++){
        int n=word[i]-'a';
        if(tire[c][n] == 0){
            tire[c][n]=pos++;
        }
        c=tire[c][n];
        num[c]++;
    }
}

int Find(char word[]){

    int c=0;
    for(int i=0;word[i];i++){
        int n=word[i] - 'a';
        if(tire[c][n] == 0){
            return 0;
        }
        c=tire[c][n];
    }


    return num[c];
}

int main(){

    char word[15];

    while( gets(word) ){
        if(word[0] == NULL){
            break ;
        }
        Insert(word);
    }

    while(gets(word)){
        printf("%d\n",Find(word));
    }


    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值