HDU 4474 Yet Another Multiple Problem

Yet Another Multiple Problem

Time Limit: 40000/20000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6289    Accepted Submission(s): 1458


Problem Description
There are tons of problems about integer multiples. Despite the fact that the topic is not original, the content is highly challenging. That’s why we call it “Yet Another Multiple Problem”.
In this problem, you’re asked to solve the following question: Given a positive integer n and m decimal digits, what is the minimal positive multiple of n whose decimal notation does not contain any of the given digits?
 

Input
There are several test cases.
For each test case, there are two lines. The first line contains two integers n and m (1 ≤ n ≤ 10 4). The second line contains m decimal digits separated by spaces.
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) while Y is the minimal multiple satisfying the above-mentioned conditions or “-1” (without quotation marks) in case there does not exist such a multiple.
 

Sample Input
  
  
2345 3 7 8 9 100 1 0
 

Sample Output
  
  
Case 1: 2345 Case 2: -1
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6216  6215  6214  6213  6212 
 

听说这是个数位bfs,就是用bfs去暴力数的每一位,这里要用到同余定理,既余数只要相同,后面加一个数字,在取余的时候所得到的余数也相同,这样找到最后余数为0即可,用个pre数组记录下路径,然后就可以了

My ugly code

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <iostream>
#include <queue>

using namespace std;
const int maxn=1e4+10;
int n,m;
int a[maxn];
bool del[10],vis[maxn];/*del用于记录哪个数据可以用,vis记录余数,出现过的就不再重复出现*/
int pre[maxn];/*记录前驱,方便输出*/
char text[maxn];/*记录走过的值*/
int cas=1;

bool bfs(){

    queue<int> q;
    while(!q.empty())
        q.pop();
    memset(pre,-1,sizeof(pre));
    memset(vis,false,sizeof(vis));
    q.push(0);
    int cur;
    while(!q.empty()){
        cur=q.front();
        q.pop();
        for(int i=0;i<=9;i++){
            if(del[i] || cur==0&&i==0)
                continue ;
            int yu=(cur*10+i)%n;
            if(vis[yu])
                continue ;
            vis[yu]=true;
            q.push(yu);

            text[yu]='0'+i;
            pre[yu]=cur;
            if(yu == 0){
                return true;

            }
        }
    }
    return false;
}

void out(){

    char pout[maxn];

    int cnt=0;
    int cur=0;
    pout[cnt++]=text[cur];
    cur=pre[cur];
    while(cur != 0){
        pout[cnt++]=text[cur];
        cur=pre[cur];
    }
    pout[cnt]='\0';
    printf("%s\n",_strrev(pout));
}

int main(){

    while(~scanf("%d%d",&n,&m)){
        int tmp;
        memset(del,false,sizeof(del));
        for(int i=1;i<=m;i++){
            scanf("%d",&tmp);
            del[tmp]=true;
        }
        bool ans=bfs();
        printf("Case %d: ",cas++);
        if(ans)
            out();
        else
            printf("-1\n");
    }


    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值