Ubuntu 下的python与pip版本对应 和 pip 版本升级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/L_0000/article/details/80716111

这是python pip的一个bug:https://bugs.launchpad.net/ubuntu/+source/python-pip/+bug/1306991

方法一 使用easy_install


sudo easy_install freeze

方法二 从pip官网直接重装,重装前先卸载ubuntu的pip包

sudo apt-get remove python-pip
sudo apt-get autoremove
wget https://bootstrap.pypa.io/get-pip.py --no-check-certificate
sudo python get-pip.py

总结:
ubuntu 的pip和ubuntu的python一样版本问题很严格!
版本对应如下:
python ——-pip 相当于 python2———pip
python3 ——-pip3
另外,pip 和 sudo 下的pip 不一定一样!
这里写图片描述
从上图可以看出,(在安装miniconda后覆盖原来的python2),
python — Anaconda—-python3.6—–pip10.0
python3 —-Ubuntu自带python3.5——pip3
sudo 下pip —— Ubuntu自带python2.7 —–pip10.0(自己强制升级10.0)
唉。。头大。。。。。。

参考
后来发现:
最好的安装方法是源码安装!
但是我的网太慢。。。。。

展开阅读全文

没有更多推荐了,返回首页