ZOJ 3607 Lazier Salesgirl (贪心,模拟)

Description

Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi. But she is so lazy that she will fall asleep if no customer comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It's known that she starts to sell bread now and the i-th customer come after ti minutes. What is the minimum possible value of w that maximizes the average value of the bread sold?

Input

There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.

The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤ 10000. The third line contains n integers 1 ≤ ti ≤ 100000. The customers are given in the non-decreasing order of ti.

Output

For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input

2
4
1 2 3 4
1 3 6 10
4
4 3 2 1
1 3 6 10

Sample Output

4.000000 2.500000
1.000000 4.000000


题意:一个小姑娘烤面包卖,先给出n个客户,他们会在t[i]时间内买价值p[i]的面包,但是这个姑娘有个最大休息时间,如果每隔w时间,没有人来买面包,他就不卖了,求出使得每次平均面包价值(卖出面包总价值/卖的次数)最大的情况下,最小的间隔时间。

思路:先求出要卖出第i个面包,最小时间间隔wi[i]。在O(N)复杂度下,遍历每个顾客,当遇到一个顾客正在买第i个面包时,再想要等到第i+1个顾客需要延迟minw时,就可以计算一下当前的平均价值,并且与之前的maxave比较,取最大值,并记录minw。

注意:小女孩卖面包不是想停就能停的,需要在w间隔内没人来,才能停下,如果当前取得时间间隔minw>t[i + 1] - t[i],这种情况下,哪怕达到的值很大,也不能停下。

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int p[1005];
int t[1005];
int wi[1005];
int main(){
	int cases, n, i, j, pre;
	double ave, maxave, minw, sum;
	cin>>cases;
	while(cases--){
		cin>>n;
		pre = 0;
		sum = 0;
		maxave = 0;
		minw = 0;
		for(i = 0; i < n; i++){
			cin>>p[i];
		}
		for(i = 0; i < n; i++){//计算得要卖到当前的面包,最小间隔 
			cin>>t[i];
			wi[i] = max(t[i] - pre, wi[i - 1]);
			pre = t[i];
		}
		for(i = 0; i < n; i++){
			sum += p[i];
			if(i == n - 1 || wi[i + 1] > wi[i]){//如果要卖出下一个面包,需要更大的时间间隔或者已经到了最后一个,则计算一下当前的平均值 
				if(sum / (i + 1) > maxave){
					maxave = sum / (i + 1);
					minw = wi[i];
				}
			}
		}
		printf("%.6lf %.6lf\n", minw, maxave);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值