吉大ACM-1练习

An equation of the form ax + by = c is a Diophantine equation, where a, b, and c are positive integers.

Such an equation has no integer solution if the greatest common divisor of a and b does not divide c. If it does divide c, then a solution exists.

The greatest common divisor (gcd) of two positive integers, is the largest integer that divides both a and b. For example, the gcd of 2 and 6 is 2. The gcd of 9 and 12 is 3. The gcd of 15 and 7 is 1.

Given a diophantine equation, determine if it has any solutions.

Input


A positive integer, denoting the number of equations.

A diophantine equation. Each equation will be of the form: <num>x+<num>y=<num>, where <num> denotes a positive integer(<=65536). Each equation will be on a separate line and will contain no blanks.

Output


The phrase “<equation> has a solution.” if a solution exists, or the phrase “<equation> has no solution.” if one does not exist, where <equation> is the equation in question.

Sample Input

2
2x+5y=11
60x+18y=97

Sample Output

2x+5y=11 has a solution.
60x+18y=97 has no solution.

代码:

#include<stdio.h>

int gcd(int a,int b);
int main()
{
 int i,n,a,b,c;
 scanf("%d",&n);
 i=0;
 while(i<n)
 {
  scanf("%dx+%dy=%d",&a,&b,&c);
  if(c%gcd(a,b)==0)
   printf("%dx+%dy=%d has a solution.\n",a,b,c);
  else
   printf("%dx+%dy=%d has no solution.\n",a,b,c);
  i++;
 }
 return 0;
}

int gcd(int a,int b)
{
 if(a<b)
 {
  int t=a;
  a=b;
  b=t;
 }
 if(a%b==0)
  return b;
 else
  return gcd(b,a%b);
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ACM-ICPC(国际大学生程序设计竞赛)是一项面向大学生的计算机编程竞赛,涉及算法和数据结构等领域。在比赛中,选手需要解决一系列编程问题,使用合适的算法和数据结构来实现正确和高效的解决方案。 对于整理ACM-ICPC模板,以下是一些建议: 1. 了解比赛要求:首先,你需要了解ACM-ICPC比赛的具体要求和规则。这包括了解比赛所涉及的算法和数据结构,以及题目的类型和难度等。 2. 收集资料:收集与ACM-ICPC相关的资料,包括经典算法和数据结构的实现代码、常见问题的解题思路等。可以参考教材、博客、论文等资源。 3. 整理模板:将收集到的资料整理成模板。可以按照算法和数据结构的分类进行整理,例如排序算法、图算法、字符串算法等。对每个模板,添加必要的注释和示例代码,以便理解和使用。 4. 测试代码:对每个模板编写测试代码,确保它们的正确性和可靠性。可以使用已知的测试用例或自行设计测试用例。 5. 更新与扩充:定期更新和扩充模板,以适应ACM-ICPC比赛中新出现的算法和数据结构。同时,根据自己的经验和理解,对模板进行优化和改进。 6. 练习和复习:在比赛之前,利用整理好的模板进行练习和复习。尝试解决一些经典问题,使用模板中的算法和数据结构进行实现,并进行优化。 希望这些建议对你整理ACM-ICPC模板有所帮助!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值