1019. 庆功会(多重背包问题)

活动 - AcWing

为了庆贺班级在校运动会上取得全校第一名成绩,班主任决定开一场庆功会,为此拨款购买奖品犒劳运动员。

期望拨款金额能购买最大价值的奖品,可以补充他们的精力和体力。

输入格式

第一行二个数n,m,其中n代表希望购买的奖品的种数,m表示拨款金额。

接下来n行,每行3个数,v、w、s,分别表示第I种奖品的价格、价值(价格与价值是不同的概念)和能购买的最大数量(买0件到s件均可)。

输出格式

一行:一个数,表示此次购买能获得的最大的价值(注意!不是价格)。

数据范围

n≤500,m≤6000
v≤100,w≤1000,s≤10

输入样例:
5 1000
80 20 4
40 50 9
30 50 7
40 30 6
20 20 1
输出样例:
1040

解析: ​​​​​​P1776 宝物筛选(多重背包模板题)-CSDN博客

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
#include<sstream>
#include<deque>
#include<unordered_map>
#include<unordered_set>
#include<bitset>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> PII;
typedef pair<double, double> PDD;
const int N = 8e2+10, M = 1e5 + 10;
const int INF = 1e8;
int n,m;
int vv[M], ww[M];
int f[M];

int main() {
	cin >> n >> m;
	int cnt = 0;
	for (int i = 1,v,w,s; i <= n; i++) {
		scanf("%d%d%d", &v, &w, &s);
		int t = 1;
		while (s >= t) {
			vv[++cnt] = t*v;
			ww[cnt] = t*w;
			s -= t;
			t *= 2;
		}
		if (s > 0) {
			vv[++cnt] = s * v;
			ww[cnt] = s * w;
		}
	}
	for (int i = 1; i <= cnt; i++) {
		for (int j = m; j >= vv[i]; j--)f[j] = max(f[j], f[j - vv[i]] + ww[i]);
	}
	cout << f[m] << endl;
	return 0;
}

  • 9
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值