ACM Robot Motion(dfs深度优先搜索)

 

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

 Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0. 

 Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1. 

 Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

     题意是一个机器人从给定的(1,y)点出发,按照地上写的EWSN分别按东西南北的方向走,若能走出地图,输出所需步数;若形成了环,则输出在进入环前走了几步和环有几步。因是多次重复该步骤,使用dfs。

#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;

int r,c,start,ans,maxn,pou;
char g[12][12];
int book[12][12];//这个数组用来记录每个点是在第几步走到的 

void dfs(int x,int y,char p,int step){
	int tx=x,ty=y;
	if(x==0||x==r+1||y==0||y==c+1){//走出了地图,搜索结束 
		ans=step;
		pou=1;
		return ;
	}
	switch(p){//四个方向 
		case 'N':tx=x-1;break;
		case 'S':tx=x+1;break;
		case 'W':ty=y-1;break;
		case 'E':ty=y+1;break;
	}
	if(book[tx][ty]==-1){//这个点还没走过 
		book[tx][ty]=step+1;
		maxn=max(maxn,step+1);//使用max函数记录下最后的步数 
		dfs(tx,ty,g[tx][ty],step+1);
		book[tx][ty]=-1;
	}
	else{//回到了某个走过的点(形成了环,搜索结束) 
		ans=book[tx][ty];
	}
	return ;
}

int main(int argc, char** argv) {
	while(scanf("%d%d%d",&r,&c,&start)&&(r||c)){
		memset(g,'\0',sizeof(g));
		memset(book,-1,sizeof(book));
		pou=0;
		ans=0;
		maxn=0;
		for(int i=1;i<=r;i++){
			for(int j=1;j<=c;j++)
				cin>>g[i][j];
		}
		book[1][start]=0;
		dfs(1,start,g[1][start],0);
		if(pou)
			cout<<ans<<" step(s) to exit"<<endl;
		else
			cout<<ans<<" step(s) before a loop of "<<maxn-ans+1<<" step(s)"<<endl;
	}
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值