hdu1358 Period--KMP


原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1358


一:原题内容

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 
Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 
Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 
二:分析理解

一个字符串,从头到某个位置,字符串的前缀最多重复了多少次,要求输出次数,注意题意要求次数至少2次

三:AC代码
#include<iostream>
#include<string.h>
using namespace std;

char ch[1000010];
int nextval[1000010];
int len;

void GetNextval()
{
	nextval[0] = -1;
	int i = 0, j = -1;
	while (i < len)
	{
		if (j == -1 || ch[i] == ch[j])
		{
			i++;
			j++;

			//if (ch[i] != ch[j])
				nextval[i] = j;
			//else
				//nextval[i] = nextval[j];
		}
		else
			j = nextval[j];
	}
}


int main()
{
	int num = 1;

	while (scanf("%d",&len) && len != 0)
	{
		scanf("%s", ch);

		GetNextval();

		printf("Test case #%d\n", num++);

		for (int i = 2; i <= len; i++)
		{
			int mix = 2 * nextval[i] - i;     //重叠部分
			int cycleLen = nextval[i] - mix;  //循环节长度

			if (mix >= 0 && i%cycleLen == 0)
				printf("%d %d\n", i, i / cycleLen);
		}

		printf("\n");
	}



	return 0;
}


在这里解释一下:

int mix = 2 * nextval[i] - i;          //重叠部分
int cycleLen = nextval[i] - mix; //循环节长度

这两句代码。

在这个循环里,我们假设ch数组的前i个字符满足题意,即它们是周期性至少为2的周期字符数组。我们来看看周期字符数组的特点,假如是ababab#,周期3,由ab构成,此时i(这里的i==6) 指向#(只是一个代表符号,代表末尾的下一个字符),我们知道未优化的next数组next[i]代表什么意思呢,代表着前i个字符的前缀后缀最大公共元素长度。也就是说在这里next[6]=4,前缀是abab,后缀是abab。所以int mix = 2 * nextval[i] - i;就代表前缀后缀的交集长度。

那么int cycleLen = nextval[i] - mix;自然很好理解,就是获得循环节长度,在这里,就是获得ab的长度,即2。









  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值