hdu2830 Matrix Swapping II--DP

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=2830


一:原题内容

Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

Sample Input
  
  
3 4 1011 1001 0001 3 4 1010 1001 0001
 

Sample Output
  
  
4 2 Note: Huge Input, scanf() is recommended.

二:分析理解

 枚举所有的尾行,然后对于每个尾行,记录到这行为止每列连续的1的个数,为了形象起见,我们可以把每列看做宽度为1,连续个数看做它的高度。然后问题就可以看做在一些高度可能为0的相邻矩形中找到最大矩形,即最大长方形那道题,如下图。


此题的另外一个条件是可以将列任意移动,我们肯定要尽量将高度大的放在一起,所以,我们可以将高度从小到大排序,然后有h[i-1]<=h[i],
即如果将1,2......i个矩形连在一起,它的高应该是h[1],所以面积显然是h[1] * i。
然后我们就枚举i从1到n,就可以解决这个问题了。

预处理出每个点下方有多个连续的1即cnt[i][j],对每行的cnt值从大到小排序,枚举列dp即可,dp[i]表示以第i行为上边的矩形的面积最大值,转移方程:dp[i] = max(dp[i], j * cnt[i][j])

三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>  

using namespace std;

int a[1005];
int dp[1005];

int main()
{
	int n, m;
	char ch;

	while (~scanf("%d%d", &n, &m))
	{
		int ans = -1;

		for (int i = 1; i <= n; i++)
		{
			getchar();
			for (int j = 1; j <= m; j++)
			{
				scanf("%c", &ch);

				if (ch == '1')
					a[j]++;
				else
					a[j] = 0;

				dp[j] = a[j];
			}

			sort(dp + 1, dp + m + 1);

			for (int k = 1; k <= m; k++)
			{
				if (dp[k] * (m - k + 1) > ans)
					ans = dp[k] * (m - k + 1);
			}
		}

		printf("%d\n", ans);
	}

	return 0;
}





  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值