Silver Cow Party (最短路)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

思路

这道题用到了最短路的思想。这道题的要求也是单向的路径,在编写代码的时候需要注意一下。

#include <iostream>
#include <stdio.h>
#include <cstring>


using namespace std;
int n,m,x,minn,u,ans=0;
int ai,bi,ti;
int f[1005][1005];
int dis[1005],book[1005],way[1005];
const int inf=99999999;

void distant(int x)
{//book[]数组用来记录查询过的点
    for(int i=1;i<=n;i++)
        book[i]=0;//重置book数组

    book[x]=1;

    for(int i=1;i<=n;i++)//记录点i到x的距离
        dis[i]=f[x][i];

    for(int i=2;i<=n;i++)
    {
        minn=inf;
        for(int j=1;j<=n;j++)//两个农场之间取最短的路径
        {
            if(!book[j]&&dis[j]<minn)
            {
                minn=dis[j];
                u=j;
            }
        }
        book[u]=1;
        for(int j=1;j<=n;j++)
        {
            if(!book[j]&&dis[j]>dis[u]+f[u][j])
                dis[j]=dis[u]+f[u][j];
        }
    }
}

int main()
{
    while(scanf("%d %d %d",&n,&m,&x)!=EOF){
    for(int i=0;i<=n;i++)//这里i的范围要取小于n,如果取小于1005z则会runtime error
    {//重置数组
        for(int j=0;j<=n;j++)
        {
            if(i==j)
            {
                f[i][j]=0;
            }
            else
            {
                f[i][j]=inf;
            }
        }
    }
    for(int i=0;i<m;i++)
    {
        scanf("%d %d %d",&ai,&bi,&ti);
        if(f[ai][bi]>ti)
            f[ai][bi]=ti;
    }
    distant(x);
    for(int i=1;i<=n;i++)
        way[i]=dis[i];//记录distant函数之后的dis的数据

    for(int i=1;i<=n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            int tem;
            tem=f[j][i];
            f[j][i]=f[i][j];
            f[i][j]=tem;
        }
    }
    distant(x);
    for(int i=1;i<=n;i++)
    {
        ans=max(ans,way[i]+dis[i]);
    }
    printf("%d\n",ans);}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值