Silver Cow Party - 最短路(逆矩阵)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requiresTi (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2..  M+1: Line  i+1 describes road  i with three space-separated integers:  Ai, Bi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:

N头牛在N个农场,要到第x个农场,去的时候路可能与回来的时候不同,因为边是单向的。问所有牛来回最短时间的最大值是多少,去的时候很简单,把x设为原点,用dijkstra算法求出每个点到x的距离,回来的时候把矩阵转置,这时再用dijkstra算法,这时求得就是x到各点的最短距离了,比如x到n的最短距离:<x,v1>,<v1,v2><v2,n>,转置后<n,v2>,<v2,v1><v1,x>为n到s的最短距离。

注意转置操作:

for(int i=1;i<=n;i++){
        for(int j=i+1;j<=n;j++){
            swap(cost[i][j],cost[j][i]);
        }
}

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 99999999
using namespace std;
//d1[i]表示点i到x点的最短路径,d2[i]表示x到点i的最短路径
int d1[1003],d2[1003],cost[1003][1003],vis[1003];
int n;

void dijkstra(int s,int d[]){
    for(int i=1;i<=n;i++){
        d[i]=INF;
    }
    d[s]=0;
    memset(vis,0,sizeof(vis));

    for(int k=1;k<=n;k++){
        int v=-1;
        for(int i=1;i<=n;i++){
            if(!vis[i]&&(v==-1||d[i]<d[v]))v=i;
        }
        vis[v]=1;
        for(int i=1;i<=n;i++){
            d[i]=min(d[i],d[v]+cost[v][i]);
        }
    }
}

int main(){
    int m,x,a,b,t;
    scanf("%d%d%d",&n,&m,&x);
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if(i==j)cost[i][j]=0;
            else cost[i][j]=INF;
        }
    }
    while(m--){
        scanf("%d%d%d",&a,&b,&t);
        cost[a][b]=t;
    }
    dijkstra(x,d1);
    for(int i=1;i<=n;i++){
        for(int j=i+1;j<=n;j++){
            swap(cost[i][j],cost[j][i]);
        }
    }
    dijkstra(x,d2);
    int ans=0;
    for(int i=1;i<=n;i++){
        if(i==x)continue;
        ans=max(ans,d1[i]+d2[i]);
    }
    printf("%d\n",ans);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值