Cow Bowling (动态规划)

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

思路

这道题用到的是动态规划的思路。做这道题需要记录前一步所计算得到的结果对此进行比较,从而得到最大的总和

数组b就是用来记录上一步所得到的结果

当程序跳出最后的循环的时候,数组b的最后结果是这样的

30

23 21

20 13 10

7   12 10 10

4   5   2    6    5

 

#include <iostream>
#include <stdio.h>
#include <cstring>

using namespace std;
int n;
int a[360][360];
int b[360][360];
int main()
{
    while(scanf("%d,",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<=i;j++)
                scanf("%d",&a[i][j]);
        /*for(int i=0;i<n;i++)
        {
            for(int j=0;j<=i;j++)
            {
                printf("%d ",a[i][j]);
            }
            cout<<endl;
        }*/
        for(int i=0;i<n;i++)
        {
            b[n-1][i]=a[n-1][i];
        }
        for(int i=n-2;i>=0;i--)
        {
            for(int j=0;j<=i;j++)
            {
                b[i][j]=a[i][j]+max(b[i+1][j],b[i+1][j+1]);
            }
        }
        /*for(int i=0;i<n;i++)
        {
            for(int j=0;j<=i;j++)
            {
                printf("%d ",b[i][j]);
            }
            cout<<endl;
        }*/
        printf("%d ",b[0][0]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值