POJ 1025(LIS+二分查找)

Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines. 

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one. 

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads. 

For example, the roads in Figure I are forbidden. 



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^ 
 

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file. 
 

Output

For each test case, output the result in the form of sample. 
You should tell JGShining what's the maximal number of road(s) can be built. 
 

Sample Input

    
    
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output

    
    
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.

Hint

 Huge input, scanf is recommended. 
         


题意:

有n个富裕的城市和n个贫穷的城市,要在富裕的城市和贫穷的城市间修建道路,要求两条路不能交叉,求最大能修多少条路。


思路:

把富裕城市的看成起点,贫穷城市看出终点,用结构体存储起点和终点,然后按起点从小到大,终点从小到大排序,

然后LIS。这样,修建城市时只需要判断起点比它小的城市,终点是否比它大。


具体代码如下:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=1e5+100;
int m,dp[maxn],b[maxn];
struct node
{
    int r;
    int p;
} c[maxn];

int cmp(node x,node y)
{
    if(x.r!=y.r)
        return x.r<y.r;
    return x.p<y.p;
}

int main()
{
    int count1=1;
    while(~scanf("%d",&m))
    {
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&c[i].r,&c[i].p);
            dp[i]=1;
        }
        sort(c+1,c+m+1,cmp);
        int l,k,mid,maxi=0,len=0;
        for(int i=1; i<=m; i++)
        {
            int num=c[i].p;
            l=1;
            k=len;
            while(l<=k)  // 用二分查找不会超时
            {
                mid=(l+k)>>1;
                if(b[mid]<=num)
                    l=mid+1;
                else
                    k=mid-1;
            }
            b[l]=num;
            dp[i]=l;
            if(l>len)
                len=l;
            if(dp[i]>maxi)
                maxi=dp[i];
        }
        if(maxi>1)  //注意,修建的道路达到两条的时候rode加上s,我就栽在这上面过。
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",count1++,maxi);
        else
            printf("Case %d:\nMy king, at most %d road can be built.\n\n",count1++,maxi);
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值