10115 Automatic Editing

Text-processing tools like awk and sedallow you to automatically perform a sequence of editing operations

based on a script. For this problem weconsider the specific case in which we want to perform

a series of string replacements, within asingle line of text, based on a fixed set of rules. Each rule

specifies the string to find, and thestring to replace it with, as shown below.

Rule Find Replace-by

1. ban bab

2. baba be

3. ana any

4. ba b hind the g

To perform the edits for a given line oftext, start with the first rule. Replace the first occurrence

of the f ind string within the text by thereplace by string, then try to perform the samereplacement

again on the new text. Continue until the find string no longer occurs within the text, and then move

on to the next rule. Continue until all therules have been considered. Note that (1) when searching

for a f ind string, you always startsearching at the beginning of the text, (2) once you have finished

using a rule (because the f ind string nolonger occurs) you never use that rule again, and (3) case is

significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence oftransformations is shown below, where occurrences of a f ind

string are underlined and replacements areboldfaced. Note that rule 1 was used twice, then rule 2 was

used once, then rule 3 was used zero times,and then rule 4 was used once.

Before After

banana boat babana boat

babana boat bababa boat

bababa boat beba boat

beba boat behind the goat

Input

The input contains one or more test cases,followed by a line containing only 0 (zero) that signals the

end of the file. Each test case begins witha line containing the number of rules, which will be between

1 and 10. Each rule is specified by a pairof lines, where the first line is the f ind string and the second

line is the replace by string. Following all the rules is a line containing the text toedit.

Output

For each test case, output a linecontaining the final edited text.

Note: Both f ind and replace by strings will be at most 80 characters long. f ind strings willcontain

at least one character, but replace by strings may be empty (indicated in the input file by an empty

line). During the edit process the text maygrow as large as 255 characters, but the final output text

will be less than 80 characters long.

The first test case in the sample inputbelow corresponds to the example shown above.

Sample Input

4

ban

bab

baba

be

ana

any

ba b

hind the g

banana boat

1

t

sh

toe or top

0

Sample Output

behind the goat

shoe or shop



这道题的要点是两个,一是对于匹配字符串的查找;二是对于字符串的替换;

我使用了string.find和string.replace;

需要注意的是string.find没有找到目标时,返回的是string :: npos;

同时需要注意正行读入时有关回车的问题;


#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#include<set>
#define pi 3.14159265358979323846
using namespace std;
string s[100],t[100];
string tar;
string :: size_type pos;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        cin.get();
        for(int i=0;i<n;++i)
        {
            getline(cin,s[i]);
            getline(cin,t[i]);
        }
        getline(cin,tar);
        for(int i=0;i<n;++i)
        {
            pos=tar.find(s[i]);
            if(pos==string :: npos)
            {
                continue;
            }
            else
            {
                int len=s[i].size();
                tar.replace(pos,len,t[i]);
                --i;
            }
        }
        cout<<tar<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值