hdu 1198 Farm Irrigation

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8438    Accepted Submission(s): 3614


Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map  

ADC
FJK
IHE

then the water pipes are distributed like  


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.  

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?  

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

Output
For each test case, output in one line the least number of wellsprings needed.
 

Sample Input
  
  
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output
  
  
2 3
 

Author
ZHENG, Lu
 

Source
 

Recommend
Ignatius.L



这道题的关键在于如何把图形之间的关系用代码表示出来;
我的办法是最蠢的一种方法,就是挨个枚举,一共只有11种;
从头到尾遍历图,如果发现没访问过的,就从这点开始深搜;


#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#include<set>
#include<functional>
#define pi 3.14159265358979323846
using namespace std;
int M,N;
int maze[51][51];
bool vis[51][51];
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};
bool judge(int x,int y,int dir)
{
    bool flag=false;
    if(x+dx[dir]<0||x+dx[dir]>=M||y+dy[dir]<0||y+dy[dir]>=N)
        return false;
    if(dir==0)
    {
        if((maze[x][y]==2||maze[x][y]==3||maze[x][y]==4||maze[x][y]==7||maze[x][y]==8||maze[x][y]==9||maze[x][y]==10)&&(maze[x+dx[dir]][y+dy[dir]]==0||maze[x+dx[dir]][y+dy[dir]]==1||maze[x+dx[dir]][y+dy[dir]]==4||maze[x+dx[dir]][y+dy[dir]]==6||maze[x+dx[dir]][y+dy[dir]]==7||maze[x+dx[dir]][y+dy[dir]]==9||maze[x+dx[dir]][y+dy[dir]]==10))
            flag=true;
    }
    else if(dir==1)
    {
        if((maze[x][y]==0||maze[x][y]==1||maze[x][y]==4||maze[x][y]==6||maze[x][y]==7||maze[x][y]==9||maze[x][y]==10)&&(maze[x+dx[dir]][y+dy[dir]]==2||maze[x+dx[dir]][y+dy[dir]]==3||maze[x+dx[dir]][y+dy[dir]]==4||maze[x+dx[dir]][y+dy[dir]]==7||maze[x+dx[dir]][y+dy[dir]]==8||maze[x+dx[dir]][y+dy[dir]]==9||maze[x+dx[dir]][y+dy[dir]]==10))
            flag=true;
    }
    else if(dir==2)
    {
        if((maze[x][y]==1||maze[x][y]==3||maze[x][y]==5||maze[x][y]==6||maze[x][y]==8||maze[x][y]==9||maze[x][y]==10)&&(maze[x+dx[dir]][y+dy[dir]]==0||maze[x+dx[dir]][y+dy[dir]]==2||maze[x+dx[dir]][y+dy[dir]]==5||maze[x+dx[dir]][y+dy[dir]]==6||maze[x+dx[dir]][y+dy[dir]]==7||maze[x+dx[dir]][y+dy[dir]]==8||maze[x+dx[dir]][y+dy[dir]]==10))
            flag=true;
    }
    else if(dir==3)
    {
        if((maze[x][y]==0||maze[x][y]==2||maze[x][y]==5||maze[x][y]==6||maze[x][y]==7||maze[x][y]==8||maze[x][y]==10)&&(maze[x+dx[dir]][y+dy[dir]]==1||maze[x+dx[dir]][y+dy[dir]]==3||maze[x+dx[dir]][y+dy[dir]]==5||maze[x+dx[dir]][y+dy[dir]]==6||maze[x+dx[dir]][y+dy[dir]]==8||maze[x+dx[dir]][y+dy[dir]]==9||maze[x+dx[dir]][y+dy[dir]]==10))
            flag=true;
    }
    return flag;
}
void dfs(int x,int y)
{
    if(vis[x][y]) return ;
    vis[x][y]=1;
    int tx,ty;
    for(int i=0;i<4;++i)
    {
        tx=x+dx[i];
        ty=y+dy[i];
        if(judge(x,y,i))
            dfs(tx,ty);
    }
}
int main()
{
    while(scanf("%d %d",&M,&N)!=EOF)
    {
        if(M<=0||N<=0) break;
        char c;
        for(int i=0;i<M;++i)
        {
            for(int j=0;j<N;++j)
            {
                scanf(" %c",&c);
                maze[i][j]=c-'A';
            }
        }
        //for(int i=0;i<M;++i)
        //{
        //    for(int j=0;j<N;++j)
        //    {
        //        printf(" %d",maze[i][j]);
        //    }
        //}
        memset(vis,0,sizeof(vis));
        int ans=0;
        for(int i=0;i<M;++i)
        {
            for(int j=0;j<N;++j)
            {
                if(vis[i][j])
                    continue;
                else
                {
                    ++ans;
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值