poj 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 68738 Accepted: 21645

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:   N  and   K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


一道简单的bfs题,只是注意要剪枝;

#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#include<set>
#include<functional>
#define pi 3.14159265358979323846
using namespace std;
int N,K;
struct point
{
    int x;
    int step;
};
bool vis[100005];
int bfs()
{
    memset(vis,0,sizeof(vis));
    point temp;
    temp.x=N;
    temp.step=0;
    vis[N]=1;
    queue<point> q;
    q.push(temp);
    point a,b,c;
    while(!q.empty())
    {
        temp=q.front();
        q.pop();
        if(temp.x==K) return temp.step;
        a.x=temp.x-1;
        a.step=temp.step+1;
        if(a.x>=0&&a.x<=100000&&vis[a.x]==0)
        {
            vis[a.x]=1;
            q.push(a);

        }
        b.x=temp.x+1;
        b.step=temp.step+1;
        if(b.x>=0&&b.x<=100000&&vis[b.x]==0)
        {
            vis[b.x]=1;
            q.push(b);
        }
        c.x=temp.x*2;
        c.step=temp.step+1;
        if(c.x>=0&&c.x<=100000&&vis[c.x]==0)
        {
            vis[c.x]=1;
            q.push(c);
        }
    }
}
int main()
{
    scanf("%d %d",&N,&K);
    if(N>=K)
    {
        printf("%d\n",N-K);
    }
    else
    {
        int ans=bfs();
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值