poj 3750 小孩报数问题

小孩报数问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12616 Accepted: 5740

Description

有N个小孩围成一圈,给他们从1开始依次编号,现指定从第W个开始报数,报到第S个时,该小孩出列,然后从下一个小孩开始报数,仍是报到S个出列,如此重复下去,直到所有的小孩都出列(总人数不足S个时将循环报数),求小孩出列的顺序。

Input

第一行输入小孩的人数N(N<=64) 
接下来每行输入一个小孩的名字(人名不超过15个字符) 
最后一行输入W,S (W < N),用逗号","间隔

Output

按人名输出小孩按顺序出列的顺序,每行输出一个人名

Sample Input

5
Xiaoming
Xiaohua
Xiaowang
Zhangsan
Lisi
2,3

Sample Output

Zhangsan
Xiaohua
Xiaoming
Xiaowang
Lisi

Source



专门练了一下,双向循环链表,当然直接暴力也行;
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<stdlib.h>
using namespace std;
string s[65];
struct node
{
    int x;
    node* front;
    node* rear;
};
node* create(int n)
{
    node *head,*temp;
    head=temp=new node;
    for(int i=2;i<=n;++i)
    {
        temp->rear=new node;
        temp->rear->front=temp;
        temp=temp->rear;
    }
    temp->rear=head;
    head->front=temp;
    return head;
}
node* move(node* p,int step)
{
    for(int i=1;i<step;++i)
    {
        p=p->rear;
        //cout<<p->x<<endl;
    }
    return p;
}
node* remove(node* p)
{
    p->front->rear=p->rear;
    p->rear->front=p->front;
    p=p->rear;
    return p;
}
int main()
{
    int N;
    scanf("%d",&N);
    int W,S;
    node *head,*temp;
    head = temp = create(N);
    for(int i=1;i<=N;++i)
    {
        cin>>s[i];
        temp->x=i;
        temp=temp->rear;
    }
    scanf("%d,%d",&W,&S);
    temp=move(head,W);
    while(temp->rear!=temp)
    {
        temp=move(temp,S);
        cout<<s[temp->x]<<endl;
        temp=remove(temp);
    }
    cout<<s[temp->x]<<endl;
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值