POJ - 2115 C Looooops (扩展欧几里得)

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28344 Accepted: 8117

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER



题目大意:给你一个程序 for(variable = A; variable%(2^k) != B; variable += C) ,题目给出A,B,C,k。问你这个程序如果能终止,最多循环多少次,如果不能终止输出:“FOREVER”。

题目思路:直接模拟这个程序肯定是不行的,根据这个程序我们可以列出一个等式 (A + x*C)%(2^k) = B; 此处的x便是我们所要求的答案,我们再把这个等式进行一些变换可以得到:A + x*C = B + (2^k)*y -> C*x - (2^k)*y = B - A;便得到了一个形如ax+by=c的等式了,接下来只需要借助扩展欧几里得算法,便可以很轻松地求得答案了。(注意,这里的结果和y的正负无关,所以转换的时候b可以直接等于(2^k))。


AC代码如下:

#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f3f
#define FIN freopen("in.txt","r",stdin)
#define fuck(x) cout<<'['<<x<<']'<<endl
using namespace std;
typedef long long LL;
typedef pair<int, int>pii;
const int MX = 100 + 10;

LL gcd(LL a, LL b) {
    return b == 0 ? a : gcd(b, a % b);
}

void ex_gcd(LL a, LL b, LL &d, LL &x, LL &y) {
    if(!b) {
        d = a;
        x = 1;
        y = 0;
    } else {
        ex_gcd(b, a % b, d, y, x);
        y -= x * (a / b);
    }
}

LL solve(LL a, LL b, LL c) {
    LL d = gcd(a, b);
    if(c % d)
        return -1;//若方程无解,则说明无法退出循环,返回-1;
    else {
        a /= d;
        b /= d;
        c /= d;
        LL D, x, y;
        ex_gcd(a, b, D, x, y);
        x = (x * c) % b;//扩展解系,求得最小的x;
        while(x < 0)
            x += b;
        return x;
    }
}

LL A, B, C;
int k;

int main() {
    //FIN;
    while(cin >> A >> B >> C >> k) {
        if(A == 0 && B == 0 && C == 0 && k == 0) break;
        LL b = (LL)1 << k;
        LL a = C, c = B - A;
        LL ans = solve(a, b, c);
        if(ans == -1)
            puts("FOREVER");
        else
            cout << ans << endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值