文本反转-栈

5 篇文章 0 订阅

Description

云龙团长喜欢用相反的方式写单词。给出一行由团长写的文本,你应该把所有的单词倒过来,然后输出它们。

Input

输入包含多个测试用例。
输入的第一行是一个整数T,它是测试用例的数量。
每个测试用例包含一行,包含多个单词。一行最多有1000个字符。

Output

T行处理过的文本。

Sample Input 1 

3
olleh !dlrow
m'I morf .udh
I ekil .mca

Sample Output 1 

hello world!
I'm from hdu.
I like acm.

AC:

#include<iostream>
#include<stack>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
	int n,sb=0;
	cin>>n;
    char a[100000];
    stack<char>wo;
	for(int i=0;i<=n;i++){
        int f=0;
		cin.getline(a,100000);
		for(int j=0;j<strlen(a);j++){
			if(a[j]==' '){
				while(!wo.empty()){
                    cout<<wo.top();
                    wo.pop();
                }cout<<" ";
                f=1;
			}else wo.push(a[j]);
		}while(!wo.empty()){
            cout<<wo.top();
            wo.pop();
        }if(f==1)cout<<endl;
	}return 0;
}

  • 11
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值