Phone List----Trie树

题目描述

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES

解法

这道题目我是用Trie树解的,这题可以说是Trie树的模板题。这题的关键在于如何对模板进行修改
很多人对这题的第一想法是,既然题目要找当前的这个串是不是里面所有串的子串,那么我按字符串长度对这些字符串进行排序,这个方法我不知道会不会超时,不过做是的确可以做出来的。
其实没必要进行排序,我们直接在FIND函数中每次进行字符查询的时候,查看目前的字符所在的位置是否是一个单词形成的位置即可,即进行简单的判断。
tip:下面的tree代表Trie树,root代表上一状态对应的子树的位置,id代表目前的字符所在的位置。
下面的话的意思是,如果当前字符在Trie树中存在且该位置的字符和之前的字符可以组成一个单词。
若if(tree[root][id]&&is_digit[tree[root][id]])改条件成立,则说明该字符串是某个字符串的子串或者某个字符串是该字符串的子串,此时只需要记录即可,若存在该种情况,则输出NO;反之输出YES;
代码如下:

#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
#define maxn 100010
int tree[maxn][11];
int is_digit[maxn];
int tot=0;
bool flag=1;
void build_tree(char str[])
{
    int root=0;
    for(int i=0; i<strlen(str)-1; i++)
    {
        int id=str[i]-'0';
        if(!tree[root][id])
            tree[root][id]=++tot;
        root=tree[root][id];
    }
    is_digit[root]=1;
}
void Find(char str[])
{
    int root=0;
    bool temp=0;
    for(int i=0; i<strlen(str)-1; i++)
    {
        int id=str[i]-'0';
        if(tree[root][id]&&!is_digit[tree[root][id]])
            root=tree[root][id];
        else if(tree[root][id]&&is_digit[tree[root][id]])
            break;
        else
        {
            temp=1;
            break;
        }
    }
    if(!temp)
        flag=0;
}
void init()
{
    for(int i=0; i<=tot; i++)
    {
        is_digit[i]=0;
        for(int j=0; j<11; j++)
            tree[i][j]=0;
    }
    tot=0;
    flag=1;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        cin>>n;
        getchar();
        for(int i=0; i<n; i++)
        {
            char str[20];
            fgets(str,15,stdin);
            if(flag)
            {
                Find(str);
                build_tree(str);
            }
        }
        if(flag)
            cout<<"YES"<<'\n';
        else
            cout<<"NO"<<'\n';
        init();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_春与修罗

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值