Phone List(trie树)

D - Phone List
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers: 
1. Emergency 911 
2. Alice 97 625 999 
3. Bob 91 12 54 26 
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent. 
 

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input

       
       
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output

       
       
NO YES
 
第二次写了一个静态版的trie树,结果Wa了九次,原来是自己逗逼了, 以为在insert()里每次结尾就标记一下,结果就忽略了如
91
9
这种情况了。之后因为数组大小的问题又Wa了几次。

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
#include<map>
using namespace std;
#define T 10005
#define inf 0x3f3f3f3f
#define CRL(a) memset(a,0,sizeof(a))
typedef long long ll;
struct trie
{
	int kid[15];
	trie()
	{
		CRL(kid);
	}
}tr[T<<5];
char s[10005][1005];
int c,flag;
void insert(char s[])
{
	int i,x=0,d;
	for(i=0;s[i];++i){
		d=s[i]-'0';
		
		if(tr[x].kid[d]==0){
			tr[x].kid[d]=++c;
			x=c;
		}
		else
			x=tr[x].kid[d];
	}
}
bool find(char s[])
{
	int i,x=0,d;
	for(i=0;s[i];++i){
		d=s[i]-'0';
			x=tr[x].kid[d];	
	}
	for(i=0;i<=9;++i)
		if(tr[x].kid[i]){flag=1;break;}
		return flag==1?true:false;
}
int main()
{
	/*freopen("input.txt","r",stdin);*/
	int n,m,i;
	scanf("%d",&n);
	while(n--)
	{
		c = 0;flag=0;
		scanf("%d",&m);
		for(i=0;i<m;++i){
			scanf("%s",&s[i]);
			insert(s[i]);
		}
		for(i=0;i<m;++i){
			if(find(s[i])){flag=1;break;}
		}
		if(flag)
			printf("NO\n");
		else
			printf("YES\n");
		for(i=0;i<(T<<5);++i){
			CRL(tr[i].kid);
		}
	}
	return 0;
}



     字典树要有一定的链表基础,感觉学起来困难就看看链表与树就OK了。
AC代码:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
const int T = 10;
struct trie
{
	trie* kid[T];
	trie()
	{
		for(int i=0;i<T;++i)
		{
			kid[i]=NULL;
		}
	}
}*root;
void insert(string str)
{
	trie* t=root;
	for(int i=0;str[i];++i)
	{
		int d=str[i]-'0';
		if(t->kid[d]==NULL)
		{
			t->kid[d] = new trie;
		}
		t=t->kid[d];
	}
}
int find(string str)
{
	trie* t=root;
	for(int i=0;str[i];++i)
	{
		int d = str[i] - '0';
		t = t->kid[d];
	}
	for(int i=0;i<T;++i)
	if(t->kid[i]!=NULL)
		return 1;
	return 0;
}
void Deal(trie* t)
{
	if(t==NULL)return;
	for(int i=0;i<10;++i)
	{
		if(t->kid[i]!=NULL)
		{
			Deal(t->kid[i]);
		}
	}
	delete t;
}
int main()
{
	/*freopen("input.txt","r",stdin);*/
	string str[10100];
	int n,m,f;
	cin >> n;
	while(n--)
	{
		root = new trie;//这个要写在循环里面,因为删除动态内存时会将根节点也删了
		f=0;
		cin >> m;
		for(int i=0;i<m;++i)
		{
		  cin >> str[i];
		  insert(str[i]);
		}
		for(int i=0;i<m;++i)
		{
			if(find(str[i])){f=1;break;}
		}
		if(f)
			cout << "NO" << endl;
		else
			cout << "YES" << endl;
		Deal(root);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值