【UVa】1600 – Patrol Robot

23 篇文章 0 订阅

Problem

A robot has to patrol around a rectangular area which is in a form of m x n grid (m rows and ncolumns). The rows are labeled from 1 to m. The columns are labeled from 1 to n. A cell (i, j)denotes the cell in rowi and column j in the grid. At each step, the robot can only move from one cell to an adjacent cell, i.e. from (x, y) to (x + 1, y), (x, y + 1), (x – 1, y) or (x, y – 1). Some of the cells in the grid contain obstacles. In order to move to a cell containing obstacle, the robot has to switch to turbo mode. Therefore, the robot cannot move continuously to more than k cells containing obstacles.
Your task is to write a program to find the shortest path (with the minimum number of cells) from cell (1, 1) to cell (m, n). It is assumed that both these cells do not contain obstacles.

Input

The input consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.
For each data set, the first line contains two positive integer numbers m and n separated by space (1 m, n 20). The second line contains an integer number k (0 k 20). The ith line of the next m lines contains n integer aij separated by space (i = 1, 2,…, m;j = 1, 2,…, n). The value of aijis 1 if there is an obstacle on the cell (i, j), and is 0 otherwise.

Output

For each data set, if there exists a way for the robot to reach the cell (m, n), write in one line the integer number s, which is the number of moves the robot has to make; -1 otherwise.

Sample Input

3
2 5
0
0 1 0 0 0
0 0 0 1 0
4 6
1
0 1 1 0 0 0
0 0 1 0 1 1
0 1 1 1 1 0
0 1 1 1 0 0
2 2
0
0 1
1 0

Sample Output

7
10
-1

Solution

bfs



#include <iostream>

#include <queue>

#include <vector>

#include "memory.h"



using namespace std;



int map[30][30];

bool visit[30][30][30];

int n, m;

int ans;

int goToX[] = {0, 0, 1, -1};

int goToY[] = {1, -1, 0, 0};



struct Node{

    int x;

    int y;

    int k;

    int step;

};



void bfs(int k){

    Node ns;

    queue<Node> nodes;

    ns.x = 0;

    ns.y = 0;

    ns.k = k;

    ns.step = 0;

    nodes.push(ns);

    while(!nodes.empty()){

        ns = nodes.front();

        nodes.pop();

        if(ns.x == m-1 && ns.y == n-1){

            ans = ns.step;

            return;

        }

     Node visited;

     if(ns.k >= 0){

        for(int i = 0; i < 4; i++){

            visited.x = ns.x + goToX[i];

            visited.y = ns.y + goToY[i];

            visited.step = ns.step+1;

            if(map[visited.x][visited.y]){

                visited.k = ns.k-1;

            }else{

                visited.k = k;

            }



            if(visited.x >= 0 && visited.x < m && visited.y >= 0 && visited.y < n && !visit[visited.x][visited.y][visited.k]){

                if(visited.k >= 0){

                    nodes.push(visited);

                    visit[visited.x][visited.y][visited.k] = true;

                    }

                }

            }



        }

    }

    ans = -1 ;   

}



int main(){



    int dataSetSize;

    while(cin >> dataSetSize){

        while(dataSetSize --){

            memset(map, 0, sizeof(map));

            memset(visit, false, sizeof(visit));

            int k;

            cin >> m >> n;

            cin >> k;

            for(int i = 0; i < m; i++){

                for(int j = 0; j < n; j++){

                    cin >> map[i][j];

                }

            }

            bfs(k);

            cout << ans << endl;

        }



    }



    return 0;

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值