Codeup100000597问题 A: Set Similarity (25)

题目描述:

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出:

50.0%
33.3%

实现代码1:

#include <cstdio>
#include <cstdlib>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <math.h>
#include <set>
using namespace std;

double Percent(set<int> st1[],int a,int b){
	set<int>::iterator it;
	double Nc=0;	//两个集合共享的不同公共数的数量 
	double Nt=st1[a].size();	//在两个集合中不同数字的总数 
	for(it=st1[b].begin();it!=st1[b].end();it++){
		if(st1[a].find(*it)!=st1[a].end()){
			Nc++;
		}else{
			Nt++;
		}
	}
	return Nc/Nt*100;
}

int main()
{
	int N;	//N个集合 
	double Nc;	//两个集合共享的不同公共数的数量 
	double Nt;	//在两个集合中不同数字的总数 
	while(scanf("%d",&N)!=EOF){
		set<int> st[55];
		int M;	//M个数据 
		for(int i=1;i<=N;i++){
			scanf("%d",&M);
			int a;
			for(int j=0;j<M;j++){
				scanf("%d",&a);
				st[i].insert(a);
			}
		}
		int K;	//K行查询 
		scanf("%d",&K);
		int c,d;		//查询的俩组 
		for(int i=0;i<K;i++){
			scanf("%d%d",&c,&d);
			printf("%.1f%\n",Percent(st,c,d));
		}
	}
	return 0;
}

实现代码2:

#include <cstdio>
#include <cstdlib>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <math.h>
#include <set>
using namespace std;

int main()
{
	int N;	//N个集合 
	double Nc;	//两个集合共享的不同公共数的数量 
	double Nt;	//在两个集合中不同数字的总数 
	while(scanf("%d",&N)!=EOF){
		set<int> st[55];
		int M;	//M个数据 
		for(int i=1;i<=N;i++){
			scanf("%d",&M);
			int a;
			for(int j=0;j<M;j++){
				scanf("%d",&a);
				st[i].insert(a);
			}
		}
		int K;	//K行查询 
		scanf("%d",&K);
		int c,d;		//查询的俩组 
		for(int i=0;i<K;i++){
			scanf("%d%d",&c,&d);
			Nc=0;
			Nt=st[c].size();
			set<int>::iterator it;
			for(it=st[d].begin();it!=st[d].end();it++){
				if(st[c].find(*it)!=st[c].end()){
					Nc++;
				}else{
					Nt++;
				}
			}
			printf("%.1f%\n",Nc/Nt*100);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值