【算法笔记第6.2节 set】问题 A: Set Similarity (25)(集合的相似度)

问题 A: Set Similarity (25)

题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出

50.0%
33.3%

题目说的是:先计算两个集合去重后的交集Nc,然后计算两个元素并集并去重Nt,两者相除。

#include <stdio.h>
#include <set>
#include <algorithm>
using namespace std;
set<int> st[100];

int main(){
	int n,index=1;
	scanf("%d",&n);
	for(int i=0;i<n;i++){ //依次放入set集合里。index作为组集合的标号; 
		int M,m;
		scanf("%d",&M);
		for(int j=0;j<M;j++){
			scanf("%d",&m);
			st[index].insert(m); 
		}
		index++;
	}
	
	int sum,k1,k2;
	
	scanf("%d",&sum);
	for(int i=0;i<sum;i++){
		scanf("%d %d",&k1,&k2);
		int temp=0;
		set<int> all;  //记录并集 
		for(set<int>::iterator it=st[k1].begin();it!=st[k1].end();it++){
			all.insert(*it);
			if(st[k2].find(*it)!=st[k2].end()){//在第k2中查找是否存在 
				temp++; // 记录交集的个数 
			}
		}
		
		for(set<int>::iterator it=st[k2].begin();it!=st[k2].end();it++){
			all.insert(*it);
		}
		double ans=double(temp*100)/double(all.size());//注意强转
		printf("%.1f%%\n",ans);
	}
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值