Codeup100000625问题 A: Fibonacci

题目描述:

The Fibonacci Numbers{0,1,1,2,3,5,8,13,21,34,55…} are defined by the recurrence:
F 0 = 0 ; F 1 = 1 ; F n = F n − 1 + F n − 2 , n ≥ 2 F_{0}=0 ;F_{1}=1;F_{n}=F_{n-1}+F_{n-2},n \ge 2 F0=0F1=1Fn=Fn1+Fn2,n2
Write a program to calculate the Fibonacci Numbers.

输入:

Each case contains a number n and you are expected to calculate Fn.( 0 ≤ n ≤ 30 0 \le n \le 30 0n30) 。

输出:

For each case, print a number Fn on a separate line,which means the nth Fibonacci Number.

样例输入:

1

样例输出:

1

实现代码1:

#include<cstdio>

const int maxn = 35;
int f[maxn];

void Fibonacci() {
    f[0] = 0;
    f[1]=1;
    for(int i = 2; i < maxn; i++) {
        f[i] = f[i - 1] + f[i - 2];
    }
}

int main() {
    int n;
    Fibonacci();
    while(scanf("%d", &n) != EOF) {
        printf("%d\n", f[n]);
    }
    return 0;
}

实现代码2:

#include<cstdio>

int Fibonacci(int n){
    if(n==0){
        return 0;
    }
    if(n==1){
        return 1;
    }
    return Fibonacci(n-1)+Fibonacci(n-2);
}

int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        printf("%d\n",Fibonacci(n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值