Py||Greatest common divisor and Minimum common multiple

题目描述
please write a program, where the input is two positive integers, and the output is their Greatest common divisor and Minimum common multiple
输入
two positive integers, which are smaller than 1000
输出
two positive integers, which are the value of their Greatest common divisor and Minimum common multiple
样例输入 Copy
5 7
样例输出 Copy
1 35

a,b=map(int,input().split())
m=a
n=b
t=0
s=0

while(a%b!=0):
    t=a%b
    a=b
    b=t
s=m*n//b
print('%d %d'%(b,s))

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值